3

I tried this thread but it didn't work.

How can I disable super + s which previews workspaces

2
3

You can use CompizConfig to do this. (sudo apt-get install compizconfig-settings-manager in a terminal to install if it isn't on your computer already)

To open, type "CompizConfig" into your Dash, or ccsm in the terminal.

Once it's open, scroll to the "Expo" option, which can be found in the Desktop section (I assume this is in the default plugins but cannot remember for certain)

Click on Expo, and then on the Bindings tab, look at the top option (Expo key). Click on the right, where it says "<Super>s". Then either uncheck the "Enabled" box to disable it entirely, or click "Grab key combination" and enter a different combo to change it to something else. Click OK to accept your settings and you should be good to go.

Hope this helps!

5
  • I disabled it as you said, but with no effect. – Radu Rădeanu Jul 24 '13 at 16:55
  • @Radu Interesting, it seems that it's not working properly for me either - I had simply assumed this would be it (it's possible to reassign the key but the old one remains, even). Could this be a bug? (The relevant bit in dconf-editor - org.compiz.profiles.unity.plugins.expo.expo-key - is also set to "Disabled", to no avail. Most odd. – Jez W Jul 24 '13 at 17:02
  • even changing the shortcut doesn't work. I tried different shortcuts but the preview is binded to super+s and super+shift+s – Sourabh Jul 24 '13 at 17:22
  • @Sourabh Apparently it used to work - see askubuntu.com/questions/62045/… - but doesn't any more. I can only assume that this is a bug of some kind... – Jez W Jul 25 '13 at 8:56
  • !!!!!!!!!!!!!!!! Compiz Config -> Expo -> Bindings -> Expo Key – Karl Morrison Nov 7 '16 at 15:57
2

in is interrupting any "super" key combination by default settings.

To disable workspaces preview with or (and allowing other apps to grab this shortcut) I had to:

  1. Disable (or change) the Compiz "expo" plugin shortcut in (run sudo apt-get install compizconfig-settings-manager && ccsm) in Desktop > expo > binding > expo key
  2. Change the unity dash key (from to anything else you like) to prevent it to interrupt all "super+..." bindings (again in CompizConfig) in Desktop > Ubuntu Unity Plugin > Launcher > Key to show the Dash, Launcher and Help Overlay. I set it to [control+super] to still be able to hit it with a single finger.

Hope this helps.

0

Using dconf-editor, set org.gnome.shell.keybindings.toggle-overview to [].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.