1

I'm using 13.04.

I want to make gmrun run when I press Alt + F2. I've already made Alt + F2 disabled

  1. I add custom shortcut in All-settings/Keyboard/Shortcuts

    enter image description here

    Everything works fine.

  2. I reboot and the shortcut doesn't work (Nothing happens).

  3. I click on Alt+F2, press Alt+F2 and the shortcut works again

I've tested it with few key combinations.

  • Alt+F2, Alt+F6, Alt+P - situation as described above.
  • Menu,Ctrl+F2 - works fine

The question is how to make shortcut on ALt+F2 permanent

4
  • Have you tried with other keys? Alt+F2 is already used by the system (by default). – edwin Jul 24 '13 at 16:00
  • @edwin, I've already disabled Alt+F2 in system. I've tried with Alt+F6 too. – RiaD Jul 24 '13 at 16:01
  • Works fine with menu, through. – RiaD Jul 24 '13 at 16:02
  • I've noticed that there is Alt(Tap) and Alt(hold) default shortcuts. And it may be the problem. I've managed to switch off first, but not the second(which doesn't seem to work). Any ideas? – RiaD Jul 30 '13 at 14:37
0

I make it working using CompisConfig Settings Manager.

First of all I didn't understand when others shortcuts with Alt start working. I believed It was right after I disabled "Key to show the HUD" in "Ubuntu unity plugin" section is CCSM but they still work now, when I reenable it.

You need to Disable "Key to execute command" in "Ubuntu unity plugin" section and also disable "Run Dialog" in "Gnome compatibility" section.

screen

To disable any shortcut you need click to current shortcut and remove "Enabled" checkbox, then "OK"

screenscreen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.