I have repeatedly tried to install 13.04 on my minitower to no avail. The installation invariably stops with a totally black screen - or frozen cursor on a black screen - after the splash screen.

First, I thought it was an UEFI problem, but it didn't get better after disabling UEFI. Second, I figured it must be a problem with the graphics card, but the installation still stalled after when using nomodset, and also the acpi = off and nolapic.

I have basically tried everything in these articles: UEFI and My computer boots to a black screen, what options do I have to fix it?. Moreover, I have checked disks and memory and found no faults, and the BIOS has been upgraded to the latest version. Both CD and USB booting has been tried.

Could it be that installing 13.04 on this PC is actually impossible?

Note: This PC already got Win 7 on it, but I want to erase that and replace it with Ubuntu. In other words; I am not looking to dual boot.

Spec: Asrock X79 Xtreme6 P2.20 motherboard with Intel i7-3820, no overclocking, 16 GB memory, AMD HD 6870 graphics card.

  • "Disabling UEFI" probably doesn't really disable EFI-mode booting. To ensure you're attempting a BIOS-mode boot, enter your firmware's boot manager, typically by pressing a function key. Most will then show two options to boot your CD or USB flash drive. One options will include the string "EFI" or "UEFI" and the other won't. The EFI/UEFI option boots in that mode and the other one boots in BIOS mode. Alternatively, try the Mac version of the Ubuntu installer, which ironically lacks EFI support, thus forcing a BIOS-mode boot. – Rod Smith Jul 24 '13 at 22:13
  • Tried just about everything, including the USB-boot above. Now I am getting a little bit beyond stalling just after the Ubuntu installer splash screen, but it still fails. – ElToro1966 Jul 29 '13 at 9:39
  • I was able to get 13.04 half-way installed with the Windows installer, but when I restarted to complete the install, it stops with the following error: – ElToro1966 Jul 29 '13 at 9:41
  • (verbose mode): ata7:00: failed command: IDENTIFY PACKET DEVICE – ElToro1966 Jul 29 '13 at 9:49

If you're not installing from your optical drive, try unplugging it. The IDENTIFY PACKET DEVICE error indicates a problem with your optical drive. If that gets the system booting, you can try plugging the device back in to another port (according to online reports, like this one, the problem can sometimes go away by changing the device to another disk controller). It might also be worth trying a new cable to the optical drive. If you're lucky, a kernel update might fix the problem, too. If not, and if unplugging the optical drive works, you might try filing a bug report with Ubuntu about this.

  • Thanks, Rod. THat was really helpful: It worked! :) Note to others: The installation also stalled on "usb 2.1.7 new hig-speed USB device number 5 using ehci-pci". The "IDENTIFY PACKET DEVICE" error above and the USB error appeared intermittently. Moreover, the installation stalled if any hardware was connected to any USB 3.0 or USB 2.0 port. UEFI had no effect on the issues (tried switching safe boot on and off without any effect). Will report. – ElToro1966 Aug 1 '13 at 8:27
  • Almost forgot: Changing cables didn't improve the situation. Only disconnecting the optical drive works, i.e., the drive does not work with Ubuntu 13.04 at all. It works, seemingly without a hitch, with Windows 7. The optical drive is an ASUS DRW-24B3ST. This drive has been causing problems in some (but not all) earlier versions of Ubuntu, at the very least in combination with an Asrock motherboard, see also ubuntuforums.org/showthread.php?t=361237&page=59. – ElToro1966 Aug 1 '13 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.