How to configure FTP server in my Ubuntu 12.04 or 13.04.What to install and how to configure.

| improve this question | | | | |
  • I'm not allowed to comment yet... so I post here regarding the previous comment. Beware of: local_umask=022 It should be: local_umask=0022 022 needs a leading 0 to be interpreted as an octal number (instead of decimal), which is the idea of the mask. Otherwise you will suffer trying to understand why those weird permissions are being set in the files you upload... for example, 022(decimal) is actually 0026(octal). – maganap Apr 11 '14 at 12:56

To install an FTP server, try out vsftpd. To install, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install vsftpd

Once installed, you need to edit the config file

sudo gedit /etc/vsftpd.conf

Make sure that you change the items shown in the image below.

enter image description here

Once done, do

sudo service vsftpd restart

For more info and documentation, visit vsftpd and FTP Server Guide on Ubuntu

| improve this answer | | | | |
  • You might want to change your umask setting while your at it. local_umask 022 Otherwise your files will get uploaded with 600 permissions. – TecBrat Feb 13 '14 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.