I've got a little problem trying to set brightness on a AcerAspireOne D255 on which I freshly installed Xubuntu 13.04 (32x)... brightness seems to play its own way: it doesn't respond to my inputs and on screen it constantly appears a flashing light bulb, even if I don't type on keyboard...

I've tried to fix the problem editing the /etc/default/grub at line GRUB_CMDLINE_LINUX="" with GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\"" then update and reboot, but no way...

[Got to say, I tried this strategy on my other Asus X501A having a similar brightness problem on Ubuntu 13.04 (64x) and everything now works perfectly!]

Thank you for your answers


1 Answer 1


It seems as though this is a problem with at least a few different models of Acer laptops. This is what worked for me.

When booting, hold down shift to enter GRUB (if it doesn't automatically), click 'e' in GRUB and add the following to the line that begins with 'linux':

acpi_osi=Linux acpi_backlight=vendor

NOTE: The 'L' in 'acpi_osi=Linux' needs to be capitalized.

Now hit go ahead save and boot. Give it 30+ seconds to complete the boot process and then try to change the brightness using your keyboard (NOTE: Sometimes the increase and decrease brightness buttons are reversed.

If this works, add the proceeding line to your /etc/default/grub.

Hope this helps!

  • This did the trick for me (Acer Aspire 5750G)
    – ali_m
    Jan 30, 2014 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.