2

The default sounds levels of master volume 100%, application/stream 100%, are too loud through my headphones.

I can adjust applications or the master volume down, but if a new application makes a sound it is deafening. Also The master volume has reset to 200% before when fiddling with the equalizer - so I'm kind of scared of relying on that now

At the moment I adjust the master, but I have it close to 25% meaning a slight increase will usually make it too loud.

Previously when using ALSA, I could have the PCM volume set to 25% then adjust the master volume from 0-100%. However now in pulse audio if I set the PCM volume and then change master volume the PCM will be reset to 100%.

Any suggestions? I've pretty much stopped listening to music because I'm (some what irrationally) scared of it now

4

From Ubuntu 9.10 the GNOME mixer behaviour changed thus making sound mixing done by Pulse Audio inconsistent. Depending on the distribution version you run you may also suffer from this. According to bug #322909 #30 it may help to ignore PCM volume settings rather than mergin them by editing /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common as root and changing the entry

[Element PCM]
volume = merge

to

[Element PCM]
volume = ignore

After that a system reboot is needed for changes to take effect.

There may be other options in this file (that controls ALSA/Pulseaudio) you could try out if the above does not help. There are some explanatory notes on possible settings.

Don't forget to backup the original file before you apply changes.

  • That worked perfectly, thank you, I can now set the PCM volume using alsamixer and adjust the master using keyboard/gui. Any ideas of gotchas that could potentially reset the PCM? I'm still pretty nervous with my headphones on lol >_< PCM is set down to 16% now, should given an indication of just how loud it was – matt Mar 29 '11 at 13:09
  • Did not work for me. Any other ideas? – panzi Jun 27 '16 at 19:31
  • Thank you SO much: I struggled with this problem for so long (and I still wonder why Ubuntu set this asinine default to start with... :( ) – R1ck77 Aug 10 '18 at 10:10
  • Minor note: you don't need to reboot for the changes to take effect. Just issue pulseaudio -k in a terminal, this will kill the current pulse audio daemon, without the need to reboot – R1ck77 Aug 10 '18 at 20:21
  • 1
    @R1ck77 only works if auto-spawn is enabled, which may not always be the case. – Takkat Aug 11 '18 at 17:11
2

In Ubuntu 16.04, I edited the file /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common.

In line 128 I changed volume = merge to volume = ignore and it worked perfectly.

0

Have you tried adjusting the PCM volume through alsamixer? It has worked for me where the gtk-based thingy failed miserably.

  • I tried using alsamixer to adjust the PCM, I can then adjust the master volume in it as well but as soon as I use the GUI tools/keyboard to adjust the master volume the PCM will jump back to 74%, which would result in another deafening >_< @Kdesu – matt Mar 29 '11 at 12:52
0

I agree with Eraser. Run alsamixer from command line. You do have both installed, or at least you should, and they aren't independent of each other.

  • 1
    PulseAudio changes the alsamixer level back to 100% though. – panzi Jun 27 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.