3

I'm trying to get my magic mouse to work on Ubuntu 13.04. When I connect it, everything works fine (haven't tested gestures). However, when I touch it with more than 2 touch points, it crashes and fails to work. My guess is that I need specific drivers for this mouse on ubuntu but I can't find which ones.

The magic mouse I'm talking about is the 100% touch, one button wireless. It seems that ubuntu can't handle more than 2 touch points, but how can I get it to work so it supports 3 or more?

  • As the questioner himself already answered another bluetooth dongle helps. This has helped me as well as other people. The following link points to an issue of touchegg (the only reliable software in ubuntu to configure multitouch actions known to me): code.google.com/p/touchegg/issues/detail?id=59 The misbehaving hardware mentioned there is: Cambridge Silicon Radio, Ltd Bluetooth Dongle USB Bluetooth 1.1 ...and that's exactly the one I was using. Would be interesting if our questioner was using this hardware too. – neun24 Jan 8 '14 at 10:39
  • 1
    Trust USB Adapter 17772 Bluetooth 3.0 – Anyone Feb 1 '14 at 10:53
1

So after trying out numerous things, including different bluetooth managers, different USB ports, searching for drivers etc.. The problem lies within the hardware. I have tested it with another Bluetooth dongle and it works better.

Issues that remain: - Can't fix the mouse speed without hacking - Can't fix the scrollspeed without hacking - Mouse randomly stopped working

Therefore I have decided to stop trying.

  • You may like to ask another question for the yet to be solved issue (include a link in that question so everyone can see what have you tried) also, you could offer a bounty. – Braiam Aug 30 '13 at 15:21
0

First of all, there seems to be a bug in the Bluetooth Manager. Install blueman and reboot to fix this.

# sudo apt-get install blueman
# sudo reboot

If this doesn't help in your situation, try following the steps on this article to "pair" the device properly:

https://wiki.ubuntu.com/Multitouch/AppleMagicMouse

  • 1
    This does not work, I have tried it with 2 different bluetooth managers. – Anyone Jul 24 '13 at 7:42
0

https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=b1a1442a23776756b254b69786848a94d92445ba is a bug. and the fix is to patch the kernel but Unfortunately with new bluetooth version even my keyboard and mouse do not work smile I switched to wire solution for the time being. Pity that if something works gets broken wink

-2

This article will help you in your quest.

  • 2
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Braiam Aug 30 '13 at 15:19
  • 1
    This articles does not help me. – Anyone Feb 1 '14 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.