3

Samba share "scanning" when just clicking on the network tab works perfect when the workgroup setting matches the windows workgroup

   workgroup = WORKGROUP

This is fine for a desktop but when I use my laptop and connect to many networks and try to connect to the network shares nothing shows until i update that line with the current workgroup. I can connect if i know the hostname (eg smb://hostname)

Windows PC's list all networks OK, Is there a way i can set Samba to do the same ?

I dont have administrator access to any of the shares and its unlikely the same name will be chosen for the 3.

0

Yes,

you can do that by running multiple Samba instances with different /etc/smb/smb.conf files. For example you can have the files /etc/smb/smb.conf.homenet and /etc/smb/smb.conf.worknet with different workgroup = options. You can then start them as root by:

service smb.homenet start
service smb.worknet start

I've certainly missed something so for more information have a look at:

https://wiki.samba.org/index.php/Multiple_Server_Instances

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.