I recently bought an Asus Zenbook UX32A. Now I'm trying to dualboot it with XP and Ubuntu 13.04.

Both OS's seem to have installed correctly but I just can't boot into grub to let me choose wich OS I want to use. By default XP loads.

I've created separate partitions on my SSD and HDD.
I would like to share the ssd for both OS's but keep all the documents and stuff on the hdd, so I mounted /var and /home to the hdd. / is on the SSD

this is my fdisk output:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xc61722b1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda2            2046   169228287    84613121    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda4   *   169228288   322826239    76798976    7  HPFS/NTFS/exFAT
/dev/sda5            2048     7812594     3905273+  83  Linux
/dev/sda6         7815168    15626239     3905536   82  Linux swap / Solaris
/dev/sda7        15628288   169228287    76800000   83  Linux

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sdb: 32.0 GB, 32017047552 bytes
255 heads, 63 sectors/track, 3892 cylinders, total 62533296 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xfed1007e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048    30722047    15360000   83  Linux
/dev/sdb2   *    30722048    62529535    15903744    7  HPFS/NTFS/exFAT

Disk /dev/sdc: 8095 MB, 8095006720 bytes
255 heads, 63 sectors/track, 984 cylinders, total 15810560 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xefacefac

Here is my Boot Repair log

Might the failure to load GRUB 2 be linked to some EFI-thing? All help will be truly appreciated, I'm actually stuck!


5 Answers 5


I never trust automatical tools, like Boot Repair. This question is fine example of why do they not deserve my trust. I've seen many ways of how one can manually do the things that BR does. Steps you should perform:

  1. Boot from LiveCD/LiveUSB
  2. Launch Terminal: Ctrl+Alt+T
  3. Run:

    sudo su
    mount /dev/sdb1 /mnt
    grub-install --root-directory=/mnt /dev/sdb
    for i in /sys /proc /run /dev; do mount --bind "$i" "/mnt$i"; done
    chroot /mnt
    umount /mnt/dev /mnt/proc /mnt/sys /mnt/run /mnt
  4. Reboot, enter your BIOS and check that you boot from /dev/sdb

After that, your Ubuntu should start without problems.

Also you may refer to:

  • root@ubuntu:/home/ubuntu# grub-mkconfig -o /mnt/boot/grub/grub.cfg /usr/sbin/grub-probe: error: failed to get canonical path of /cow.
    – lorin
    Jul 24, 2013 at 10:17
  • Edited my answer. This way is longer but should not throw errors.
    – Danatela
    Jul 24, 2013 at 10:23
  • the first answer (before editing) did work for me! the only thing left was doing an update-grub. Now it's working like a charm! thanks a million!
    – lorin
    Jul 24, 2013 at 10:42
  • I recently had to do a clean install and this one helped me again! thanks :)
    – lorin
    Mar 24, 2014 at 15:50

I hope I'm able to help. I recently dual-booted my ASUS X55C running Windows 8 With Ubuntu 12.04LTS and encountered several problems along the way and resolved them.

The first thing I learned was in order to boot into linux you'll need to go into your BIOS, which since you've dual-booted I'd assume you already know how to do so. I'd imagine it's a bit different on XP, but if you don't know how to then turn off your PC and on boot up you'll either need to press F2, f5, f10, SHIFT, DELETE. Or whatever other keys that could boot BIOS, it depends on your computer those are the most common ones, mine was DELETE, you could google your computers specific one and if you can't find anything it's trial and error. Sometimes it tells you what to press on boot up.

When you find out which it is, on boot up immediately keep pressing that key until the BIOS show up. They'll look something like this:


Now you're going to want to find your secure boot option and disable it if it is not already disabled, Ubuntu needs it disabled in order to run.

Now find the BOOT options tab, and locate BOOT OVERRIDE. If it's not in BOOT options it could be under SAVE&EXIT like it is on Windows 8. In BOOT you can also change which is default so you don't have to override. Under BOOT OVERRIDE you should see your Windows XP and Ubuntu partitions, to boot into XP highlight it and press enter, to boot into GRUB highlight the Ubuntu one and press enter.

If successful when you select the Ubuntu option, your GRUB should appear. From GRUB you should be able to select Ubuntu and boot in normally.

For me GRUB displayed both my Ubuntu and Ubuntu Recovery options as well as the same two for Windows 8.

The problem I had is that you can't boot into windows 8 from GRUB due to the invalid EFI shell. So everytime you wish to switch OS's you have to go through your BIOS.

Now with XP you may not have this issue, I don't know what XP's boot requirements are. For Windows 8 you have to activate CSM mode and use boot repair in linux, and then when your computer boots it will automatically boot into GRUB and you have a new UEFI windows option in GRUB so you can easily switch OS's

In order to do that follow the instructions on the answer here: Dualbooting Windows 8 and Ubuntu 12.04?

There may be other boot managers for XP, so you could do some research there. Otherwise, you'll have to go through your BIOS on every boot up to switch OS's.

I hope that helped some, I know this is more of a help for Windows 8, but I think some if not most of this will apply to XP.

  • Well, Windows XP & 7 should boot from GRUB without any additional actions required for Windows 8
    – Danatela
    Jul 24, 2013 at 4:28
  • That's what I figured, It's been awhile since I've worked on XP and I've never booted Linux alongside 7, but I figured some of this stuff may help. It could be simply that GRUB isn't set to be the default boot, which could be set from the BIOS. Unless XP sets it up that way automatically like you said it should. In which case it probably is a GRUB issue which means you can provide way more help for this user than I can. I hope everything gets resolved!
    – Casey
    Jul 24, 2013 at 4:44
  • I'm waiting for Boot Repair information. The fdisk output does not contain info about bootloaders.
    – Danatela
    Jul 24, 2013 at 4:51
  • Well I have some handy experience in dual-booting especially after my recent Windows 8-Ubuntu dual-boot, so if it turns out not to be a GRUB issue, I'll be around to provide any extra relevant help if I can. Boot Repair worked for me so I hope that it's nothing too serious and can be easily resolved.
    – Casey
    Jul 24, 2013 at 5:04
  • Please spend some time and introduce with frequent questions for better assistance.
    – Danatela
    Jul 24, 2013 at 5:42

GRUB 2 is version 1.98 or later. GRUB 2 is the default boot loader and manager for Ubuntu since version 9.10 (Karmic Koala).

The following procedure can be applied to Ubuntu, just in commands, replace grub2-install with grub-install.

If you can boot into Ubuntu/live-Fedora, use its grub2 to configure


Check if "GRUB_DEFAULT=saved" is there.

sudoedit /etc/default/grub

Now create a config file and check it.

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

grub2-editenv list

Even use grub-set-default to set the default. Refer to Ubuntu grub wiki for further customization.

If you cant boot into your ubuntu/fedora, use Ubuntu-live, you can install lilo, and repair your MBR, by

sudo apt-get install lilo and sudo lilo -M /dev/sda mbr

good luck

  • hi, I tried this and it didn't do the trick... But thanks anyway!
    – lorin
    Jul 23, 2013 at 19:01
  • my ssd and hdd are GPT, does that make a difference?
    – lorin
    Jul 23, 2013 at 19:50
  • @lorin, that means you boot from /dev/sdb and Windows XP bootloader got there somehow. However, without Boot Repair log I cannot be sure. Please provide it.
    – Danatela
    Jul 24, 2013 at 4:55
  • Yes, I chose to boot from sdb, this is my ssd. I did the lilo cmd on both sda and sdb.
    – lorin
    Jul 24, 2013 at 8:28
  • No, your bios will search for a boot-loader. You should only choose one system to be responsible for your booting. In case of dual-booing, linux is recommended. Then with the help of GRUB/LiLo you can have boot options to choose your OSes. Don't just apply lilo on both of your sda,sdb. I recommend you follow the grub instructions, in your ubuntu.
    – Saeed
    Jul 24, 2013 at 8:55

XP will not work from gpt partitions. And with BIOS XP needs special drivers to work with AHCI which are not normally included.

I dual booted Ubuntu with 10.10 installed on a gpt drive and chain loaded from grub to a install of XP in another drive that was MBR(msdos). But XP does not have any drivers to even see a NTFS data partition on a gpt partitioned drive.

When I got my SSD, I turned on AHCI, so trim would work, and XP stopped working. I was able to turn AHCI back off and boot XP, but that is such a hassle that I finally stopped using XP. There are drivers for AHCI, but the install process after XP is installed is rather complex.


OK, this is how it works. I have just done it.

  1. Install the XP and choose to partition the HD and format the partition. if you had anything on the HD then I suggest to delete all partitions and then create partition. Must have partition to Ubuntu, don't let the Ubuntu do partition- that is where the problem starts.
  2. Install the XP
  3. Install Ubuntu- ( I have XP 64bit pro and Ubuntu 13.04)... here you basically done! 4.run all updates on XP then Ubuntu.

Good luck, :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .