I've read this article, and carefully followed the instructions provided. I am sure the wireless card in my laptop supports going into wireless access point mode.
But unfortunately, when I use the following command to start hostapd service it throws an error:

 $ sudo service hostapd stop
 Starting advanced IEEE 802.11 management hostapd                      [fail] 

The instructions mentioned above said this could possibly be because my wireless card does not support the g mode, and provided the wiki of hostapd.
But what is g mode? I tried to switch to a, or b mode, but it just didn't work.

Can anyone help with this or recommend a tool like connectify in windows ?

ps. I am using Ubuntu 12.04, 32 bit. I have an ADSL wired network, and I want to share it by setting my laptop into a WiFi hotspot with my windows phone.


3 Answers 3


You need to create infrastructure (Access Point mode) wireless hot-spot rather Ad-hoc hot-spot. In linux(ubuntu) i used ap-hotspot and which works for me(i got connected WP8 and Android 4.4, dont know about iPhones).

For installation

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install ap-hotspot

Update for 14.04

The hostapd version in Ubuntu 14.04 is buggy and doesn't work properly. To get AP-Hotspot to work with hostapd in Ubuntu 14.04, you need to downgrade hostapd and use apt to hold the package so it's not upgraded.

To do this, use the following commands:
For 32 Bit:

cd /tmp
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_i386.deb
sudo dpkg -i hostapd*.deb
sudo apt-mark hold hostapd

For 64 Bit

cd /tmp
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_amd64.deb
sudo dpkg -i hostapd*.deb
sudo apt-mark hold hostapd


sudo ap-hotspot configure


It will asks for interfaces, Access point name(which can be anything you want to see as wifi_hotspot name), password(which is your wifi_hotspot security key).

Now, if you able to configure successfully and dont get any kind of Unsupported wifi errors(if you get that simply means, your wifi_card doesnt support infrastrucutre Access point wifi_hotspot, so can do nothing on it), then procceed.

So just now start your hotspot as

sudo ap-hotspot start

If you want to stop then

sudo ap-hotspot stop

If you wanna see all available commands

sudo ap-hotspot

You don't see this hot-spot running in any indicator or something, i am still finding it how to determine status checking of it.

I am using is from last few weeks, and no bugs(no side-effects too) yet. I am using Gnome-Ubuntu 13.10 amd64 sharing eth0 to my WP8.

SOURCE : http://www.unixmen.com/create-infrastructure-wifi-access-point-connect-android-devices/ SOURCE : http://www.webupd8.org/2013/06/how-to-set-up-wireless-hotspot-access.html

  • NOTE for 14.04. Commented May 8, 2014 at 12:00
  • 1
    You must read the second source link if you are using Ubuntu14.04. Commented Jan 14, 2015 at 20:35
  • I have installed the ap-hotspot and when i tried to configure it it's giving me this error Your wireless card or driver does not support Access Point mode what should i do now for creating hotspot
    – Eka
    Commented Mar 26, 2015 at 4:24
  • 1
    @Eka ap-hotspot is dreprecated. Try create_ap.
    – kexanie
    Commented Nov 22, 2015 at 8:35

I have 2 wi-fi adapters installed for this. One native internal, and other via USB. I have to share with external USB because the internal one I am using to receive my conection. In your case you don't need another adapter, as you receive the conection via cable. Just follow my steps.
This is how I do. In System Settings...>Networks select the Wi-Fi adapter you want to uuse as a Hotspon, and click Use as Hotspot... button.

enter image description here

This will shortly activate the adapter to serve as a Hotspot. At the same window you have Options... function, and you can stop it in a same easy way.

enter image description here

  • 1
    Yes, I tried that method before. But it seems that it's ad-hoc mode, not AP. I am not sure my windows phone can get access to it. And when I "use as hotspot", the connection disconnected as soon as it connected sucessfully.
    – kexanie
    Commented Jul 23, 2013 at 11:22
  • I tried the same thing on Ubuntu 12.04 but it does not seem to work. What shall I do to figure out the problem?
    – Srijan
    Commented Aug 10, 2013 at 14:47
  • I guess it cannot work with .local domain. As you will need to have another domain account for each device you want to connect. Did you try to debug from here? Commented Aug 11, 2013 at 4:35

Since ap-hotspot is deprecated, it's neither reliable or stable for newer Ubuntu distribution. The author of ap-hotspot recommended create_ap.


git clone https://github.com/oblique/create_ap
cd create_ap
make install


No passphrase (open network):

create_ap wlan0 eth0 MyAccessPoint

WPA + WPA2 passphrase:

create_ap wlan0 eth0 MyAccessPoint MyPassPhrase

Change wlan0 and eth0 to the interface on your machine. (ifconfig)

  • I'm on Ubuntu 15.10, and this worked the best for me.
    – TungstenX
    Commented Jun 1, 2016 at 9:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .