I was using GTX 560 with nvidia's drivers in Ubuntu without problem. Then I have removed that video card and used Intel HD4000 for a week. After that I installed GTX 780, connected LCD with HDMI cable (no DVI on it) and it got weird.

The only resolution I have is 1024*720, SystemSettings--Displays calls my LCD a 'Laptop' and offers no options for it. SystemSettings--Software--Additional Drivers is empty.

I have tried installing nvidia driver packages from repositories with apt-get but it did no visible difference. X just does not pick them up. I just feel that writing xorg.conf in 2013 is not a right thing to do. Am I wrong?

Sure, I can just download NVIDIA drivers from their site, install drivers from binary, create xorg.conf file and be entitled to manual reinstallation of it with every kernel update. May be somebody can tell me a less awkward solution?

  • I'd like to hear what modprobe nvidia says in your case. Also, what packages did you install/configure after switching to HD4000?
    – Danatela
    Jul 23, 2013 at 6:55
  • Module is present, modprobe says nothing. When I was to remove GTX 560 I first switched to 'nouveau' with Software Sources, checked it works, then removed card and did nothing more. It just worked. Jul 23, 2013 at 12:54
  • Could you post output of lsmod? Also, switch back to GTX 560 and check if problem exists with that card. And you said that you write xorg.conf... Do you run nvidia-xconfig or write it manually?
    – Danatela
    Jul 24, 2013 at 2:31
  • I said I don't want to write xorg.conf. However, I tried nvidia-xconfig and cleared input sections from it. With that file it simply hangs at boot with screen filled with that hateful Ubuntu color. Though autostart X applications like Transmission are running, no input, no Ctrl+Alt+F1, no Ctrl+Alt+Backspace do anything. Will post lsmod tomorrow, but I assure you, nvidia-313-update module is up and loaded. Jul 24, 2013 at 5:43

1 Answer 1


I have installed CCSM, and toggled OpenGL plugin off and on there. Then did it with unity plugin. It helped. The error seems to be reproducible on several PC, including fresh install of Ubuntu. Video card version does not matter, though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .