0

I've just installed Ubuntu 13.04 and I can not figure out how to get the wireless working, wired worked fine. I have followed a few instructions on driver downloads but I really do not have a clue what I am doing. I know there is a ton more info you need so just let me know what and how to get it and I will. I am on a Gateway M-6750, I believe it is using the Marvel topdog wireless card (internal). I switched to Ubuntu 13.04 from Windows Vista. Thank you, John

Here is additional info

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

ifconfig

eth0      Link encap:Ethernet  HWaddr 00:e0:b8:e4:a7:e9  
          inet addr:192.168.6.237  Bcast:192.168.6.255  Mask:255.255.255.0
          inet6 addr: fe80::2e0:b8ff:fee4:a7e9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10154868 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6843213 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14151434429 (14.1 GB)  TX bytes:542801103 (542.8 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:36886 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36886 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2707955 (2.7 MB)  TX bytes:2707955 (2.7 MB)

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired] --------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        00:E0:B8:E4:A7:E9

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.6.237
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.6.1

    DNS:             192.168.6.1
    DNS:             64.134.255.2
    DNS:             64.134.255.10

lshw -Cnetwork

Hardware Lister (lshw) - B.02.16
usage: lshw [-format] [-options ...]
       lshw -version

    -version        print program version (B.02.16)

format can be
    -html           output hardware tree as HTML
    -xml            output hardware tree as XML
    -short          output hardware paths
    -businfo        output bus information

options can be
    -class CLASS    only show a certain class of hardware
    -C CLASS        same as '-class CLASS'
    -c CLASS        same as '-class CLASS'
    -disable TEST   disable a test (like pci, isapnp, cpuid, etc. )
    -enable TEST    enable a test (like pci, isapnp, cpuid, etc. )
    -quiet          don't display status
    -sanitize       sanitize output (remove sensitive information like serial numbers, etc.)
    -numeric        output numeric IDs (for PCI, USB, etc.)

sudo lshw -C network

*-network UNCLAIMED

description: Ethernet controller
product: 88W8362e [TopDog] 802.11a/b/g/n Wireless
vendor: Marvell Technology Group Ltd.
physical id: 0
bus info: pci@0000:02:00.0
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:f6000000-f600ffff memory:f4000000-f400ffff

*-network

description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:06:00.0
logical name: eth0
version: 01
serial: 00:e0:b8:e4:a7:e9
size: 100Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.6.237 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
resources: irq:43 ioport:4000(size=256) memory:fa200000-fa200fff memory:c0000000-c001ffff

0

Check to see which card you have, lspci -nn. Device [11ab:2a08] is Gateway 6750.

As I have read this device needs NDISwrapper, which is a free software driver wrapper that enables the use of Windows XP network device drivers (for devices such as PCI cards, USB modems, and routers) on Linux operating systems.

Make sure you have ndiswrapper, and if you get "ndiswrapper not found", follow this link. There is also a graphical interface for ndiswrapper that you can use called ndisgtk.

Now that you have NDISWrapper installed and working, You should already have the Windows driver extracted into a folder and that you are running these commands from that folder.

sudo ndiswrapper -i NetMW14x.inf
sudo ndiswrapper -a 11ab:2a08 netmw14x
sudo ndiswrapper -l
sudo ndiswrapper -m
sudo depmod -a
sudo modprobe ndiswrapper

Pay attention as you follow, the second command parameter should be the same number as your lspci result.

With -l you would check which driver is newly installed. and -m saves your configuration.

Linux kernel modules can provide symbols for other modules to use. depmod creates a list of module dependencies by reading each module under /lib/modules/version and determining what symbols it exports and what symbols it needs.

modprobe utility is used to add loadable modules to the Linux kernel. You can check how the process have been so far by viewing dmesg command result. Especially when you run the last command.

Now that you have your wireless card enabled; Check to see if you network configuration is OK,

  1. wireless is shown among your network interfaces, (along with your lan connection), (report back commands: iwconfig, ifconfig, nm-tool, lshw -C network)
  2. You can scan your wireless network, and see available networks,
  3. Your AP has given your interface correct settings (it has IP address and this address is not the same range as your LAN)
  4. you can ping your AP,
  5. you can browse the net.
  • Thank you for the response , I do know that I do not have wireless showing among my network interfaces so I can not see wireless networks and there for can not do any of the other steps. – EVObastard Jul 24 '13 at 0:18
  • I've updated my response to help you through this. you can add the results, and update your question. – Saeed Jul 24 '13 at 8:02
  • In the command sudo lshw -C network, there is a space between C and network, please correct it. If you copy paste from here, you wouldn't make typos. – Saeed Jul 25 '13 at 3:58
  • Everything looked good till I ran this sudo modprobe ndiswrapper FATAL: Module ndiswrapper not found. – EVObastard Jul 25 '13 at 20:22
  • Updated question with sudo lshw -C network I apologize but I have not yet learned how to properly post copied text in a nice format. Thank you to the person that fixed my first post. – EVObastard Jul 25 '13 at 20:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.