18

These days, I have to use the NTFS-3G driver to write to an NTFS drive (which will later be used in Windows). But I still remember the olde times of Linux ntfs driver which clearly said in the docs: 'If you write to an ntfs volume, run our special program afterwards which will clean up the damage done.'

So, I read through the man, the docs, the Tuxera site and Askubuntu and found no discussion of the write-safety of NTFS-3G. The only thing that was mentioned somewhere is that the driver doesn't support the NTFS journal.

So, the question is, can I use NTFS-3G and be sure that I will later read what I have written to the files? Won't, for example, Windows find the journal entries missing and 'clean up' the data according to its own faulty understanding?

  • 1
    In the (almost) two years since the original question, I used ntfs-3g and had no problems with it, at least none that I'm aware of. So, though not strictly confirmed, I can conclude that it should be safe to use. The only thing that bothers me is, the list of files in a directory on the NTFS partition is read too slowly. It may be due to the fact that it's an external USB drive but I've got a feeling that it's too slow even for USB (because the files themselves are read fine), and, partly for this reason, I'm going to migrate to ext4 completely. – katrmr Jan 9 '13 at 23:12
4

I've been using ntfs-3g since I started using Ubuntu when it was 9.04. I havent yet run into any issues with read/writeability using the ntfs-3g driver. You should be fine with using the ntfs-3g drivers.

| improve this answer | |
17

As you can see HERE it is 100% compatible Read/Write NTFS for Windows XP, 2000, 2003, 2008, Vista, 7 and whatever other NTFS windows system comes out or missed.

And I quote:

NTFS-3G is a stable, full-featured, read-write NTFS driver for Linux, Android, Mac OS X, FreeBSD, NetBSD, OpenSolaris, QNX, Haiku, and other operating systems. It provides safe handling of the Windows XP, Windows Server 2003, Windows 2000, Windows Vista, Windows Server 2008 and Windows 7 NTFS file systems

The performance for me (which I tested A LOT of them) is the same as using NTFS on Windows. You will not have any problems with any version of NTFS for any version of Windows.

More info here: http://en.wikipedia.org/wiki/NTFS-3G

| improve this answer | |
  • Since people still come here, I'll comment on this answer. Kind sir, I specifically said in the question that I've read the Tuxera site and, while not stated but easily guessed, I've read the Wikipedia article also. I haven't found any discussion of possible interoperability problems or damage to the filesystem and was looking for explicit clues as to whether they occur or not. The fact that they are not mentioned is not the same as their absense. And I'm not interested in the marketing statements, which is why I asked the community. I appreciate the comment on your own experience though. – katrmr Jan 9 '13 at 22:52
  • 2
    @katrmr - If it helps, I have tested NTFS-3G and even formatted partitions inside Ubuntu with it for at least 2 years. That would be around 200-300+ hard drives. None as of today have giving me any problems. They have worked as if they were working in Windows. The only problems, or better stated, most common problems are just permissions regarding the partition or drive which can be easily corrected using chmod commands and similar. Is this the answer you were looking for friend? – Luis Alvarado Jan 9 '13 at 23:22
  • yes, I think this sort of info is much more useful, thank you – katrmr Jan 10 '13 at 11:31
0

Not a problem, using ntfs3g for 4 years, and the only problems in my ntfs partitions has been caused by Microsoft's windows.

I've even used it with USBs (yes, my USBs are in NTFS because it is the only way to share movies with Microsoft's windows users...) and it works perfect.

| improve this answer | |
  • 1
    What problems were caused by Windows? (Devil's advocate) How do you know they weren't caused by NTFS-3G? – Mikel Jun 21 '15 at 15:52
  • 1
    An unexpected shutdown when the volume was mounted in Windows (the electrics went off) made the partition NTFS not being able to mount when I tried to boot Ubuntu. Just booted into Windows, shutdown normally and the problem was gone. – animaletdesequia Jun 22 '15 at 17:06
  • Maybe I should have clarified that the problem wasn't exactly caused by ntfs-3g itself, but Windows not closing the filesystem in a clean way. – animaletdesequia Jun 24 '15 at 12:22
-3

It's really bad to give false instructions to Windows users. No OS shall be meant to damage other people's data therefore it must be clear that writing an NTFS filesystem with Linux is dangerous. The NTFS must have security features that cannot be handled by Linux and such features include as well encrypted files. I don't think there is any way for Linux to do this job for the NTFS filesystem and at the same time be able not to damage the Windows Operating system. Linux can write safely only the FAT system. I am witness of real problems on my own NTFS filesystem because Linux did not give me any warning about not playing with the NTFS filesystem and I have lost all of my files. Actually, what Linux is doing is illegal because there must be a clear warning that is dangerous to write to an NTFS filesystem with a Linux OS.

| improve this answer | |
  • Wrong. It depends on your install Have a look here – Fabby Dec 30 '15 at 23:55
  • Your frustration with the loss of data is understandable, and you may have a valid point regarding writing encrypted files. But, first, your answer does not describe your actions and the problem in any clear way. And second, the question regards a particular driver and assumes technical knowledge on the part of users. So your comment would be better directed at the community and maintainers of your particular distribution—who actually can do something regarding the situation, such as enable warnings in the interface. I sincerely hope that no one has to deal with such problems in the future. – katrmr Dec 31 '15 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.