17

Im new to lubuntu have used ubuntu before there is no nm-applet in lubuntu. So how to connect? Pls help

  • Did you try sudo ifconfig wlan0 up? – Danatela Jul 22 '13 at 7:15
11

Try this. Install Network Manager. To do that, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install network-manager-gnome

Once done, you can setup the wireless network. type the following command to start the manager:

nm-applet
| improve this answer | |
  • 6
    Um, what if you don't have internet because you can't connect to wifi? – brentonstrine Jul 22 '14 at 15:40
  • @brentonstrine take a look at this askubuntu.com/questions/55805/… – Mitch Jul 22 '14 at 15:46
  • Why doesn't the initial install simply do everything it's supposed to? Why the need for the extra invocation of nm-applet? – Michael Jul 4 '18 at 3:22
  • I ran 'sudo apt-get install network-manager-gnome' on a new Lubuntu 19.04 install (with no internet access). It kicked out some errors: "Can't set a parent on widget.." and "gtk_widget_destroy:.." But a functional Network Manager showed up in the System Tray in the lower right of the LXQt desktop screen. The Network Manger worked fine: click on it to see the available WiFi signals, click on one to enter the WiFi password and get connected. – Charles May 7 at 17:45
5

Another (easier) way to have the network manager in the panel (bottom right) is this:

I am quoting from this article: Fix Lubuntu / Xubuntu 14.04 Network Manager Missing From The Panel.

To fix the Network Manager not showing up on the panel issue, from the Lubuntu menu select Preferences > Default applications for LXSession, then click on the Autostart tab and under "Manual autostarted applications" type "nm-applet", then click the "+ Add" button on the left.

Then log out and log back in. The new icon should be present in the panel - bottom right. Use that icon to manage network connections.

If this doesn't work have a look at the link above, there is more to it.

| improve this answer | |
2

The other answers may take care of things, but the thing that seemed to be important for me is to go to the main menu ("start menu") then Preferences -> Additional Drivers, and check to see if your wifi driver is available. Mine, a broadcom driver, was available but not enabled as it is proprietary

| improve this answer | |
  • 1
    Great quick way to install some proprietary drivers for your machine. Thanks for this. – DazBaldwin Jul 12 '17 at 20:31
2

Though its been long and many years since this question is posted, yet i find it meaningful to add my experience of facing the same issue with latest lubuntu version ie. 19.04. After installing lubuntu 19.04, i noticed there is no way to configure wifi connection. Network manager was not listed. There were some of posts which points to download and install driver, but how exactly you can download driver when you dont have internet connection at all. At last i followed below steps which helped me to get rid of problem-

  1. You have to provide internet connection to your system in some way. Either use lan cable to connect to broadband modem or use your smart phone's internet.

  2. I used my android phone. connected through usb cable to my laptop. After connection go to cell phone -- settings --> Network & Internet --> Hotspot and Tethering --> USB Tethring. Turn it on.

  3. As soon as I turned it on, my laptop running on lubuntu started displaying available wifi networks. i could then connect to my wifi network (it just demanded for wifi password). Lubuntu was using the network support from android device tethering. The problem is not yet solved! If you disconnect your cell phone or switch off ththering, lubuntu laptop will again loose the internet. So you need to install the drivers now to resolve it permanently.

  4. In your Lubuntu go to Start --> Preferences --> Additional Drivers . Enter you password if asked for. It will open Software Sources. Go to 'Ubuntu Software' tab. Make sure all options are checked. Source code you can ignore. Next when you click 'close', it will prompt to upgrade the outdated drivers. Click ok and continue. Let system install new drivers. Let it complete.

  5. After completion of driver downloads, go to Preferences. You should see Advance Network Configuration' available now. You can disconnect your cell phone now! Internet would continue working fine on you lubuntu system.

Hope it helps!

| improve this answer | |
1

In a terminal issue the command

sudo ifconfig wlan0 up

In the GUI

Go to Preferences-> Network Connections -> Add

Click the down arrow next to Ethernet and select Wi-Fi

In the window that opens; on the WiFi Tab, type your routers SSID in the box labelled SSID

Go to the General Tab and make sure the top two boxes are checked (you can modify these to meet your needs)

Go to the security tab and choose your routers security type (in my case WPA/WPA2 Personal)

Enter your password in the box labelled password

Save and close the window

Back in the terminal issue the command

sudo dhclient

Crank up your browser to confirm.

Full disclosure: This approach is known to work on Lubuntu 14.04 on An Asus F55A Tested and confirmed by me.

| improve this answer | |
0

A major problem with Lubuntu install is the entire lack of a simple warning: a hard wire connection to a router is needed. Then, for a MacbookPro 13... assuming Lubuntu is installed with all upgrades and updates... Click the bluebird icon at bottom left of display... Click Preferences... Click Additional Drivers and enter password... Click the button for your wireless driver... Wait to install, then reboot... After reboot, click the network icon at bottom right of display... You should now see your wifi connect in the list... Click on yours and enter password... You should now be connected.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.