I have been unable to boot Linux from a USB on my acer aspire 5750G laptop It goes through the boot and then freezes half way through. it has done this with every type of Linux I have tried. Before anyone asks I have tried every single one of these boots on my desktop computer and they work perfectly every time. This freeze only happens on my acer aspire. I have tried it on a Toshiba laptop as well and it boots perfectly again. I have tried almost everything, I say almost because posting on a forum like this is the only thing I haven't tried. Please be clear I'm not concerned with installing it onto my laptop I just want it to run off a USB. Please I really want this to work.

  • What exact point in the boot process does it stop, and are any error messages shown? What options have you selected with the function keys (if you even got that far)? – ubfan1 Jul 22 '13 at 3:47
  • When I try to install ubuntu and kubuntu it stops at a certain command while loading. I will try loading ubuntu again and I will tell you which one it stops on. However when trying to install any other sort of linux (I've tried a range of about 10-15 types of linux) there is just a black screen and it does nothing. On some I get a blinking underscore then that freezes. But I will put ubuntu back onto my USB and get back to you about the command it stops on. Thank you for your reply – markgaines Jul 24 '13 at 5:57
  • I have been researching this also and apparently other people have has problems with the GFX drivers for the nvidia 520gt in the acer aspire 5750g – markgaines Jul 24 '13 at 6:02
  • the last command that pops up while loading linux is [7.083767] [drm] nouveau 0000:01:00.0: Checking PRAMIN for VBIOS then everything stopped for about 3 mins and my laptop shut off I have a picture of my screen, but am unsure of how to post it. – markgaines Jul 24 '13 at 8:38

Looks like a video driver issue. Select the nomodeset option (under F6) at the "Try/Install" screen. Skipping some of the video install stuff is possible by typing a character at the screen with the two little icons at the bottom (a keyboard and a little stick person), then select language, ... If that doesn't get you through, try one of the alterative installs which have even less video dependence. Once you are running, you can install the appropriate proprietary video driver, and maybe add nomodeset to the /etc/default/grub file on the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line after the splash.

| improve this answer | |
  • thank you I can now load linux successfully however the video drivers don't install properly – markgaines Jul 30 '13 at 4:15

Have you tried choosing "the nvidia graphic card in the bios in order to use only the Intel integrated card (choosing 'integrated' instead of 'switchable')"?


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.