I have installed likewise-open, but when I add an Ubuntu machine (10.10) to a domain, I am getting the following error:

Leaving AD Domain:   XXX.XX.XXX`                              
Error: Lsass Error [code 0x00080047]                       
1387 (0x56B) ERROR_NO_SUCH_MEMBER - Unknown error

Can someone sort this out?

Likewise-open shows me as being connected to domain. But how do I verify this?

Likewise settings

  • AD is managed by a Windows 2003 server.

I tried red's answer but it didn't work.

root@karthick:~# domainjoin-cli join XXX.XX.COM xxxxxxx
Joining to AD Domain:   XXX.XX.COM
With Computer DNS Name: karthick.xxx.xx.com

xxxxxxx@XXX.XX.COM's password: 

Error: Lsass Error [code 0x00080047]

31 (0x1F) ERROR_GEN_FAILURE - Unknown error
  • Likewise-open Gui is already installed, but I am not able to leave the domain and re-join.
  • See the following screen shot:


I searched google and i came up with this. Is that a problem? Or can anyone help me to debug the cause?

  • 4
    NO_SUCH_MEMBER.You must add your machine using a trusted user in domain.The error says the user that you're providing to the likewise does not exist. – Pedram Mar 27 '11 at 15:55
  • 1
    Yeah i have done that already.. – karthick87 Mar 30 '11 at 5:55
  • Is the Windows domain being managed by Windows Vista/7 or by Windows 2000/XP? – RobinJ Jul 13 '11 at 9:03

I'm not sure, but you also need to edit /etc/nsswitch.conf and change "host" line like this:

hosts:    wins files mdns4_minimal [NOTFOUND=return] dns mdns4

At least, it helped me

  • Had forgotten this, was required of me as well in 10.10 but not any longer in 11.04! – red Jul 15 '11 at 15:50
  • It was already enabled,but still no use.. – karthick87 Jul 16 '11 at 14:22
  • Instead of just "username" in "domainjoin-cli" command, try to type "domain\\username" or "username@domain". Maybe this will help? Also, is there only one DC server, or you have replication servers in your network? – romancev Jul 16 '11 at 15:25
  • We have only one DC server and there was no replication servers. – karthick87 Aug 29 '11 at 9:26

Have you checked the DC to see if the computer object already exists? If it does - delete it - then try to rejoin. If you have more problems you can try running the following command listed below to get some more verbose logging:

> domainjoin-cli --loglevel verbose
> --log /tmp/domainjoin.log join domain fqdn AD account
  • In the above command what is fqdn ? – karthick87 May 8 '11 at 14:35
  • 2
    Fully Qualified Domain Name = fqdn – cprofitt May 20 '11 at 14:53
  • 3
    so the fqdn for a computer named workstation-01 on the domain disney.com would be workstation-01.disney.com – cprofitt May 20 '11 at 14:55

After searching a lot, i just find the way myself. The steps i have followed in ubuntu 10.10 to join windows domain are as follows,

  • Open up the Ubuntu Software Center.
  • Search for “centrify” (No quotes).
  • Click Install.
  • Type your sudo password and press Enter.
  • Once the installation is finished you can then close out the Ubuntu Software Center.

Configure nsswitch file:

  • Open the terminal and type the following,

    sudo editor /etc/nsswitch

  • Search for the line that says

    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

  • Put # infront of that line and add a new line

    hosts: files dns

  • So that the file will look like nsswitch file

  • Also edit the following file, sudo editor /etc/centrifydc/group.ignore

You need to add the group “admin” (no quotes) to this list. If you do not do this your sudo users will not longer have sudo privileges. Without sudo privileges your users will not be able to install applications or run anything that needs administrative permissions. Once you have configured that file, save it. You are now ready to join the domain.

Now its time to join the domain. Type the following in your terminal,

sudo adjoin -w DOMAIN -u USERNAME

You will get the following confirmation.

    karthick@karthick:~$ sudo adjoin -w XXX.XX.COM -u Administrator
    Administrator's Active Directory password: 
    Using writable domain controller: xxxxxx.xxx.xx.com
    Join to domain:XXX.XX.COM, zone:Auto Zone successful

    Centrify DirectControl started.
    Loading domains and trusts information

    You have successfully joined the Active Directory domain: XXX.XX.COM
    in the Centrify DirectControl zone: Auto Zone

    You may need to restart other services that rely upon PAM and NSS or simply
    reboot the computer for proper operation.  Failure to do so may result in
    login problems for AD users.

One way to check if domain works as should, is to get someone to log into your PC with his domain credentials. This should create a new user and let him in. I had the same username locally, as the one I had in domain I joined, and it didn't work well. I had to rename my old account and then log in from the login screen with the domain credentials to get the correct user priviledges etc. associated with my Ubuntu account.


I see you're attempting to join the domain from the command line. When I install Likewise Open, a window pops up with an easy to use GUI for joining the Domain. Have you attempted to join the domain using it instead of the CLI? In your case, clicking Leave Domain should bring it up. If not, you could try reinstalling the package and waiting a minute to see if the Wizard pops up.

enter image description here

As one final tweak, I've found out on few occasions that I have needed to add the Domain machine into the /etc/hosts file of my workstation, in order for the joining to work. fvs-dc001.ourdomain.local ourdomain.local

I replaced our actual domain name with "ourdomain" in the example above.

  • I tried but it din help.. – karthick87 Jul 13 '11 at 11:21
  • Updated answer. – red Jul 15 '11 at 8:13
  • I did this, pls see my updated question.. – karthick87 Jul 15 '11 at 12:19
  • I don't see your updated question addressing the GUI steps or problems with it? – red Jul 15 '11 at 13:09

I was getting the same issue while adding Ubuntu Machine into Windows Domain 2012 R2.

Steps I did after successfully installed LikeWise to Join.

sudo gedit /etc/nsswitch.conf

hosts:  files mdns4_minimal [NOTFOUND=return] dns mdns4


hosts:  files dns [NOTFOUND=return]

domainjoin-cli join test.local admin 


ERROR_GEN_FAILURE [code 0x0000001f]


sudo apt-get remove avahi-daemon

To Remove Ubuntu from Domain:

sudo domainjoin-cli leave

Thanks !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.