I have just bought a new laptop. Acer v7-582PG. Everything works great with Ubuntu, exept the wireless module. I have tried Ubuntu 13.04 and 13.10 Beta. Still no luck.

It is kind of a new wireless card, so there is very little information out about it.

lspci: 04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 63)

sudo lshw -c network
ubuntu@ubuntu:~$ sudo lshw -c network
  *-network UNCLAIMED     
       description: Network controller
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 63
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:b3500000-b3501fff
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:05:00.1
       logical name: eth0
       version: 14
       serial: 08:9e:01:c3:24:50
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip= latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:62 ioport:4000(size=256) memory:b3404000-b3404fff memory:b3400000-b3403fff

rfkill list all

ubuntu@ubuntu:~$ rfkill list all
0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
  • You can add information if the card by editing your question. Paste output of following lspci , sudo lshw -c network, rfkill list all
    – Web-E
    Jul 21, 2013 at 9:46
  • Show us the output of nmcli con list, nmcli -p con up id "NAME" iface wlan0 and nmcli -p con status id "NAME" iface wlan0. Where NAME is the name of the wifi you want to connect to given by nmcli con list. Jul 21, 2013 at 11:00
  • since this is a new computer, and the wireless never have worked, I have no saved WLAN yet.
    – Fyksen
    Jul 21, 2013 at 11:09
  • I think this is supposed to work with the driver iwlwifi and appropriate firmware. Please load it and check for messages in the logs: sudo modprobe iwlwifi and then do: dmesg | grep iwl
    – chili555
    Jul 21, 2013 at 13:25
  • I'm not sure where I can find the correct firmwire. And I dont know how to load it ether. Can you point me in the right direction?
    – Fyksen
    Jul 21, 2013 at 13:51

9 Answers 9


Further research, primarily here, suggests that simply loading the firmware will be ineffective. http://forum.notebookreview.com/networking-wireless/716325-intel-7260-a-6.html

I suggest you download this to your desktop: http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.11-rc3/backports-3.11-rc3-1.tar.bz2 Right-click it and select 'Extract Here.' Now open a terminal and do:

cd Desktop/backports-3.11-rc3-1/
make defconfig-iwlwifi
sudo make install

Now reboot and tell us if your wireless is working.

I tested in Ubuntu 13.04 and it compiles perfectly and correctly drives my Intel 6200, but I don't have a 7260 so I can't test further. Fingers crossed! You definitely need the firmware.

  • So is it working as expected?
    – chili555
    Jul 22, 2013 at 12:41
  • I tried this but it didn't make any difference Aug 12, 2013 at 13:14
  • @PeterLawrey ,what clues appear in: dmesg : grep iwl
    – chili555
    Aug 12, 2013 at 13:27
  • That doesn't return anything. askubuntu.com/questions/331667/… suggests an old version of the firmware is being loaded. Aug 12, 2013 at 13:31
  • 1
    This does not work for Ubuntu 12.04 Oct 12, 2013 at 17:27

Although you didn't confirm it from dmesg, it appears you need and lack the required firmware. Here is a link from my Dropbox: https://dl.dropboxusercontent.com/u/58267392/iwlwifi-7260-7.ucode.zip Please download it to your desktop. Right-click and select 'Extract Here.' Now open a terminal and do:

sudo cp Desktop/iwlwifi-7260-7.ucode /lib/firmware/
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

Do you have a wireless interface now?


Does it connect? Are there any informative messages here?

dmesg | grep iwl
  • None of that worked for me, but downloading and installing linux-3.11.0-rc4, your link to the iwlwifi-7260-7.ucode, and putting it in /lib/firmware worked! Thanks!
    – wulftone
    Aug 12, 2013 at 4:03
  • This one works on Ubuntu 12.04. But I'm wondering if this will work stable as the "iwlwifi-7260-7.ucode" is for Kernel 3.10+ and ubuntu 12.04.3 kernel is 3.8. The iwlwifi-7260-7.ucode can be downloaded from kernel.org: wireless.kernel.org/en/users/Drivers/… Oct 12, 2013 at 17:36
  • Before this, you have to do the steps in the other chili555 answer, the "make defconfig-iwlwifi" steps. Also after you got updates to the Kernel, your wifi will stop working again, you have to repeat the "make" steps and reboot. Oct 12, 2013 at 20:18

I tried installing both of those packages (the backport and the iwlwifi-7260-7.ucode), but my computer still isn't detecting a wireless card.

The guy above said it worked by downloading and installing linux-3.11.0-rc4 . Can someone please give instructions on how to do this? Like, how do I add the repository, download it, and install it? Help would be greatly appreciated, as I need to use Linux on this computer for work. Thanks


according to http://wireless.kernel.org/en/users/Drivers/iwlwifi , it seems we need a kernel-upgrade; Ubuntu 13.04 use 3.8.0 by default, which can't support n7260

wait for Ubuntu 13.10 is another solution...

I'm upgrading my kernel now ;(


I upgraded to the kernel 3.11-8 and both of the network connections work 'out of the box'.

When upgrading you might have a warning such as firmware possibly missing with names of different files needed: I fixed it with apt-file search name_of_the_file and this for each file "probably missing".


In order that your wireless card be detected - you have to go to "System Settings" -> "Additional Drivers" and Activate (turn button from grey to green) for your card. On some RTL cards there can be 2-3 or more drivers (I had on my Dell Inspiron 6400) :( - in that case try to turn off one that is not working and turn one next one - until you found right one :(((. Eorked for me (was just 3 ;-))

Hopefully this will help


I am using the same hardware as you

   description: Wireless interface
   product: Wireless 7260

Kernel version is

$ uname -a Linux nanak-P570WM 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I am using Wireless since long.

Please install the above Kernel version from


It should work.


for solve install New Package:

wget -N "http://ftp.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-iwlwifi_0.40_all.deb";

sudo dpkg -i --force-all firmware-iwlwifi_0.40_all.deb;
sudo install -f;

source : http://packages.debian.org/jessie/firmware-iwlwifi


Ubuntu 13.10, It resolved for me by :

apt-get install linux-firmware 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.