I have been trying to change my password now for a while, and every single time I get an error. Here's what I have tried so far:

  • passwd in terminal - I get a message saying the password has been changed successfully, but when I have to use it anywhere else, to login or to authenticate a change the new password doesn't work; I have to use the old one.
  • System > Users and Groups - When I use this to change the password, the password change dialog box grays out after I enter the new password and remains that way. I can close the window, but the password doesn't get changed.

Any idea what could be wrong or how to solve this? Might have to file a bug in Launchpad otherwise. FYI, I'm using 10.10 Netbook Edition.

Update: Included answer to how I solved problem. However, the problem with being unable to update passwords using the GUI 'Users and Groups' remains. The dialog box goes gray and password remains unchanged. Any idea why this could be happening / anyone else facing this?

  • 1
    If you are the owner/admin of the system, can you see whether the row with your account in /etc/shadow has changed between before and after your attempt to change password ? (you need to be root to read the /etc/shadow) – bitwelder Mar 27 '11 at 15:03
  • I came across this thread on Ubuntu Forums along similar lines but it's not really the same issue. My password is 'complex' enough. – Ankur Banerjee Mar 27 '11 at 15:03
  • @bitwelder Thanks, you tip helped. Checking the modify time showed a much older date, so I figured out the mistake I made (typing sudo passwd instead of passwd.) Edited question accordingly. – Ankur Banerjee Mar 27 '11 at 15:12

I figured out what I was doing incorrectly when trying to update using passwd - I typed in sudo passwd instead of just passwd. The latter is for changing user password, which I wanted to do. However, the problem with being unable to update passwords using the GUI 'Users and Groups' remains.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.