I'm having trouble in getting newer version opengl.

First, I get my graphics cards information using: lspci -nnk | grep VGA and it returns:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18)


02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 520M] [10de:1050] (rev a1)

When I use: glxinfo | grep Op command, it returns

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 9.0
OpenGL shading language version string: 1.20
OpenGL extensions:

My questions are:

  1. How do I get new driver to use a newer version mesa? I installed mesa 9.1.5, but it's not shown in glxinfo.
  2. how do I use my nvidia graphics card ?

I installed nvidia-current and bumblebee. I tried optirun to run a program, it worked at first, but then it crashed when I ran it again. Since I want a newer version of opengl and mesa only only supports opengl 3.1.

btw:the crash information is:

[  157.097081] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  157.097158] [ERROR]Aborting because fallback start is disabled.

How do I get opengl 4.1 or newer development package?

My laptop information (from the tag):

Acer Aspire 4743G

Intel Core i5-480m

2GB DDR3 memory

  • Can you add the computer specifications (make, model and ram) to your question bu clicking the Edit link, just under your question :) – SimplySimon Jul 20 '13 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.