1

When I try to install usb-modeswitch for making a mobile-broadband work, Ubuntu cannot download anything. Even when I tried to install Wine, it failed to connect to the internet even though I could surf websites. Links for the image:

enter image description here

enter image description here

PS- This belonged to my sister and worked on a proxy server in IIT Delhi before giving it to me. I went to Network Proxy->Direct Internet Connection so that I could use the wifi in my home. Also, as you can see in the photos that the wifi is connected and I can use it to surf the net but it cannot download anything. The Ubuntu is also unable to detect my Huawei USB Modem

  • 1
    Can you check the content of /etc/apt/apt.conf and ~/.bashrc for a line like Acquire::http::Proxy "http://repo.iitd.ernet.in"; or http_proxy=http://repo.iitd.ernet.in ? If they are there just remove them. – Samik Jul 20 '13 at 8:48
  • @Samik How do I check the contents of these? And there is no file or folder by the name of apt.conf, only apt.conf.d I cannot locate ~/.bashrc also. The version of Ubutnu is 11.04 – Kumar Saurav Jul 21 '13 at 6:09
  • first check does echo $http_proxy give you anything. If it does then see ls -a ~ | grep .bashrc shows anything or not. Then open with gedit ~/.bashrc. Also check in ~/.profile,/etc/profile and /root/.bashrc. Btw, the filenames starting with a . are hidden files(ls -a in terminal or Ctrl + H in file manager). – Samik Jul 21 '13 at 7:30
  • You have to locate a file which sets 'http_proxy' to something. You can use console command 'grep http_proxy' and add the files you want to search in after, like 'grep http_proxy ~/* ~/.* /etc/apt/apt.conf.d/*'. If there are any of those files that the text you search for, grep will write its name. – Anders Jul 21 '13 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.