My Seagate 500 GB external HDD stopped working few days ago for unknown reasons. I don't really care about the data on it anymore. I just want it to work properly again but I cant format it in Gparted or Disk Utility. In fact, I can't even see my drive in both places. I get this error when I connect it via USB:

Error mounting /dev/sdb1 at /media/sourabh/Backup: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb1" "/media/sourabh/Backup"' exited with non-zero exit status 13: The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.
ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.
Failed to sync device /dev/sdb1: Input/output error
Failed to close volume /dev/sdb1: Input/output error

How can I force format this drive?

  • "In the first case run chkdsk /f on Windows then reboot into Windows twice". You need to fix the errors on the disc from within Windows before you can mount it. – Rinzwind Jul 20 '13 at 6:50
  • I did try that, as advised on some other forum, but it didn't work. Ubuntu Disks says Reallocated Sector Count: failing. – Sourabh Jul 20 '13 at 7:35

GParted or KDE Partition Manager require an unmounted drive to operate. Given your system is detecting the drive, but refusing to mount it, you should be able to select Device, New Partition Table after selecting the correct device in either partition manager and clear everything up in about one minute, plus the time it takes to create the new filesystem.


force the format on windows via Disc manager, or however they call it now in your windoze version. This should work as well. If you prefer The Linux way, then you can list your drives by

fdisk -l | grep '^Disk'

choose which you want to re-partition and create partitions by

fdisk /dev/sdx

where you replace x for letter of your drive. Use "m" for list the fdisk help and then follow the white rabbit. Do not make a mistake in choosing your drive, you can easily kill any other drive and data.

  • fdisk -l | grep '^Disk' does nothing. – Sourabh Jul 20 '13 at 10:56
  • @ Sourabh: should be a shortened list of fdisk -l where only the lines beginning "Disk" are listed, so try it without grep. Search for line looking like Disk /dev/sda: 640.1 GB, 640135028736 bytes , maybe your localization calls disk differently... – Dee Jul 21 '13 at 20:09
  • Yes I even tried fdisk -l but it didn't do anything either. I even tried seatools software but even that was unable to detect my drive. I guess my drive's really dead – Sourabh Jul 22 '13 at 8:05
  • Yes, it is possible... check the cables, small chance, but most common reason... do the Bios see the harddisk? – Dee Jul 22 '13 at 12:48

This problem has nothing to do with Ubuntu. Your file system is corrupted as it is not properly closed in Windows. Please try the following steps in Windows (probably Win7)

  1. Check whether the disk is shown in Disk Management. To do that, goto Start -> Run -> and type "diskmgmt.msc".
  2. In the Disk Management Window, if you see the removable disk (your seagate) with unallocated space, then follow the steps below.

    • Right click on it and select "New Simple Volume", go through the wizard and create new partition.
    • If your drive is partitioned and you still can’t see it, ensure you’ve set a drive letter so you can access it in Windows. This should happen automatically, but if you’ve manually unset the drive letter, the drive may not show up and be accessible in Windows.

    • To do this, right-click the removable drive partition, select Change Drive Letter and Paths, and add a drive letter. For example, add the letter G: and the removable drive will be accessible at drive G: (any of your wish).

    • If the drive does appear to be partitioned, it may be partitioned with the wrong file system. May be with the ext4 file system from Linux. Windows can’t read these file systems. Reformat the drive with the newer NTFS file system or older FAT32 file system so Windows will be able to recognize it.

    • To reformat a partition, right-click it, select Format, and select your desired file system.

    • Note that this will erase all the files on your drive, so you’ll want to copy any important files off of it first.

  3. If you don’t see the drive in the Disk Management, then continue the following steps where we will try to determine why your drive isn’t recognized.

    • If Windows doesn’t see your drive at all, possibilities are there is a hardware issue with your computer USB port, a driver problem with your Windows computer, or you may just have a dead drive (mostly).

    • First, unplug the drive from your USB port and try plugging it into another USB port on your computer. If it works in one USB port but not another, you may have a dead USB port. If you’ve plugged the drive into a USB hub, try connecting it to the computer instead. Some USB hubs won’t provide enough power for your external drive to function

    • If the drive doesn’t show up in Disk Management even after you skip the USB hub and connect it to another USB port on your computer, it’s tough to know for certain whether the drive itself is bad or the computer is having a problem.

    • If you have another computer nearby, try plugging the drive in there to check whether it’s detected. If the drive doesn’t work on any computer you plug it into — be sure to check whether it appears in the computer’s Disk Management window — the drive itself is likely dead and will need to be replaced.

    • If the drive does work on other computers — or you don’t have another computer around to test this with — Windows may be having a driver problem with the drive. You can check the Device Manager.

    • To open it, press Windows Key + R, type “devmgmt.msc” into the Run dialog, and press Enter.

    • Look under Disk drives and check for any devices with a yellow exclamation mark next to them. If you see a yellow exclamation mark, you have a driver problem. Right-click the device with a yellow exclamation mark, select Properties, and look at the error message. This error message can help you fix the problem — you may want to perform a Google search for the error message you find

    • Such problems can be tricky to fix. If the problem started recently, you may want to run System Restore. You may want to use the Update Driver button to install an updated driver, use the Roll Back Driver button to revert any changes, or use the Uninstall button to uninstall the device from your system and hope that Windows will reinstall the driver and configure it correctly when you reconnect the drive.

By the above steps, you may come to a conclusion of your Seagate drive.

Not the answer you're looking for? Browse other questions tagged or ask your own question.