I recently got a Dell Inspiron 13z with Windows 8. I decided to dual boot Ubuntu.

After install, it was booting straight into Ubuntu, with no GRUB menu showing up. No problem. I just ran boot repair and everything seemed to work fine. (Here's the output, btw: http://paste.ubuntu.com/5891478/)

Then I booted into Windows. Now I can't seem to get back into Ubuntu. I tried disabling Fast Boot by running REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /V HiberbootEnabled /T REG_dWORD /D 0 /F in PowerShell as Administrator. Even now, GRUB is still being bypassed somehow.

What should I do?

EDIT: I tried reinstalling GRUB by booting a LiveUSB and following this: https://superuser.com/questions/376470/how-to-reinstall-grub2-efi. Unfortunately, that didn't work.


The Boot Repair tool isn't 100% reliable. The problem you seem to have run into is that Boot Repair is rather over-enthusiastic about juggling boot loader files. Specifically, Boot Repair renames the Windows boot loader and installs a copy of GRUB in its place; however, this "repair," in addition to being terribly confusing, is sometimes undone by Windows -- Windows sees the change and (quite reasonably) re-installs its own boot loader. What's more, this "repair" is seldom necessary; the tool just applies it in a scattershot approach with a bunch of other "repairs" in the hopes that it will be useful. Unfortunately, sometimes it's not, and it can cause follow-on problems.

I recommend you try this:

  1. Back up the contents of your EFI System Partition (ESP; your /dev/sda1). This will serve as a fallback in case you make matters worse.
  2. Re-run Boot Repair, but click the Advanced Options item and check the Restore EFI Backups option before proceeding. This will undo some of Boot Repair's changes.
  3. Reboot and test both Windows and Ubuntu. There's a good chance that everything will work; however....
    • If the system starts booting Windows directly, launch an Administrator Command Prompt window (not a PowerShell; it won't work) and type bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi.
    • If the system starts booting Ubuntu directly with no option to boot Windows, install my rEFInd boot manager. Installing the Debian package is the easiest way to do this. rEFInd tends to be more reliable about launching Windows than is GRUB, so this may well fix the problem.
  • How do I back up my EFI partition? – Vineel Jul 20 '13 at 0:40
  • I just did sudo dd if=/dev/sda1 of=/media/ubuntu/USB/efi.img. Hopefully that works. – Vineel Jul 20 '13 at 1:24
  • Yes, that should work, although a file-level backup (using cp or tar) would have been a little more convenient to access, if that should become necessary. – Rod Smith Jul 20 '13 at 15:17

There is a boot order list in your BIOS settings. You can try to change the order in BIOS settings.

As reported with your boot-repair link, "The boot files of [The OS now in use - Ubuntu 13.04] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (https://help.ubuntu.com/community/BootPartition)"

Does your EFI system detect it?

  • In my BIOS I see an Ubuntu and a Windows option. No matter which one I choose, Windows gets booted. Also, I believe that /dev/sda1 is my boot partition. I can't get any closer to the start of the disk. I can't create any partitions near the start of the disk since that's where Windows and recovery partitions reside. – Vineel Jul 19 '13 at 21:45
  • Yes you are right. I found solution with installing Ubuntu 13.04 64 bit version. It supports well the installation with EFI systems. There are related topics around here. – ubuntu_tr Jul 19 '13 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.