I have recently changed OS from Ubuntu 12.10 to 13.04. Then onwards my external HDD (mounted as VIVEK) became read only. When I try to create a new folder it shows an error msg as shown in figure.

Error Message

I have changed the ownership to me only but still when I use chmod 777 -fR /media/vivek/VIVEK, it is not effecting the read write and execute permissions.

Uneffected of chmod

when I try using sudo fsck -p /dev/sdb1 or sudo fsck.vfat -r /dev/sdb1 it is showing a message as "Currently, only 1 or 2 FATs are supported, not 0." When I check the properties of the hard disk, at the place of File System Format it is not showing either FAT32 or NTFS but blank.

No File System Format fsck error

Please help me out to get rid of this problem so that I can cut/copy/create new folders in my external HDD. BTW I am still able to do all these on the same external HDD when connected to any other system running on Windows.

  • 1
    The last screen hints that your Hdd is formatted as NTFS, not FAT, so fsck.vfat or fsck.msdosfs will of course not work. What output do you get, if you try to mount the HDD using command line? For fixing errors of NTFS partitions, I'd recommend to use Windows, but there's also a tool named ntfsfix (see askubuntu.com/questions/86086/fsck-cant-find-fsck-ntfs )
    – soulsource
    Jul 20, 2013 at 10:05
  • Thank you for your valuable suggestion. It was very useful for me. But still the problem is not solved. I have created a softlink for fsck.ntfs and tried sudo fsck command and it successfully checked the file-system. But I am still unable to create a new folder in that external HD.
    – Vivek
    Jul 20, 2013 at 14:25
  • I'd try mounting on the command line. Might be, that there is a warning, that the GUI doesn't show. A often encountered issue is described here: askubuntu.com/questions/112150/…
    – soulsource
    Jul 20, 2013 at 15:10

1 Answer 1


When dealing with hard drive partition, and dealing with data in general, make sure that you have a current backup just in case.

You may consider something like Clonezilla.

I hate to be the one telling you this. For the first message, I/O Error is bad. It ususally means that a section of your drive is unable to read or write. In this case it seems like it's unreadable. Which means that sections of the drive are bad, which might cause you to start loosing data.

You could try FSCK. Unmount your disk and run the sudo fdisk -l command to find out the device name of the disk, and once you find it, run:

sudo fsck /dev/sdb1

for the second issue, try

sudo dosfsck -r -v /dev/sdb1

Hope that this helps.

  • Thank you for your response. But, I have tried them and still the problem persists. Even for sudo dosfsck command also it is showing the same error msg as "Currently, only 1 or 2 FATs are supported, not 0".
    – Vivek
    Jul 20, 2013 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.