I have an HP dv7 Pavillion with AMD/Intel hybrid graphics. The AMD is a Radeon HD 6370m, totally supported by AMD. I want to run with proprietary drivers to properly play games. I've already rigorously tried:

1) The method presented by Marian Lux here;

2) The method presented here, both usual and beta (13.6) versions;

3) The method presented here by Alexislavie, properly adapted to 13.04 version (that means, downloading the driver 13.4);

4) The first method presented here by Chris Carter, except for nomodeset configuration;

5) The second method presented there in the previous link by Nick Andrik;

6) The method presented here by Rodrigo Martins.

All of them were tested in fresh new installations of Ubuntu 13.04 (imagine how much time I've wasted reinstalling --clean-- versions of Ubuntu 13.04).

The results I get:

1) Every time when the installation is successful and I can apply the sudo aticonfig --initial command (or its variants), the reboot returns me to the black screen (where it's said I'm running in "low graphics").

2) Each time when the installation seems not be successful (i.e., I can't apply the previous command or I simply don't do it - or even I restore the original xorg.conf back) I can log in but the Unity is broken, and the fglrxinfo command also returns that there's a problem.

I would even try Ubuntu 12.04 if I were sure that those problems are related to my Ubuntu version, but I don't think so. That's why I'd appreciate your help to get those drivers properly working in Ubuntu 13.04.


Just to register: I've made another --clear-- installation of Ubuntu 13.04 and tried rigorously exactly accurately... the method proposed by Rodrigo Martins. It didn't work. After rebooting, I get back to the black screen The system is running in low-graphics mode.

  • Ok, I've already seen this link, but I see no difference between the method they explain there and the ones presented above (specially the 1st, the 2nd and the 3rd). Do you see any difference? Which one? Thanks. – Tales Tomaz Jul 19 '13 at 15:43
  • What is the output of fglrxinfo? – Rodrigo Martins Jul 26 '13 at 1:50
  • +1 because even if now this question is about an EOL release (have you had any success with 13.10?), this question should be pointed as example to newcomers... – Rmano Mar 18 '14 at 22:16

Until now, the AMD proprietary drivers didn't work with Ubuntu 13.04 (graphic card Radeon 6850). But today (07 sept 13), I simply check the proprietary driver (update) in System parameters of Ubuntu, it got installed and it works ! So, it seems to have been updated.

  • These are great news! What do you mean with "proprietary driver in System parameters"? Did you try to install it through "Additional drivers", is it that? – Tales Tomaz Sep 8 '13 at 11:39
  • Unfortunately it didn't work here again. When I reboot, the Unity is broken. The command fglrxinfo returns: X Error of failed request: BadRequest (invalid request code or no such operation) Major opcode of failed request: 154 (GLX) Minor opcode of failed request: 19 (X_GLXQueryServerString) Serial number of failed request: 12 Current serial number in output stream: 12 – Tales Tomaz Sep 29 '13 at 13:14
  • @TalesTomaz can you add that to your question? Each time you try something and fail add the new information to the question. – Braiam Oct 9 '13 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.