0

I have troubles understanding how my Ubuntu 13.04 is handling the touchpad of my Macbook Pro. Very annoying because I really can't work with the unit as the touchpad keeps being very "touchy", a single slight touch with my palm is enough to move the cursor away while I'm typing stuff on the keyboard.

On a fresh install, I have the "Systeme > Souris et pavé tactil" (sorry, it's in french!) utility with the checkbox "disable while typing". Doesn't work.

So I installed gpointing-devices-settings via the Ubuntu Software Center (gsynaptics isn't maintained anymore, I read it somewhere).

Gpointingdevices-settings

Sounds like gpointingdevices handles my touchpad, but the options I check/uncheck are not persistent. Each time I re-launch gpointingdevices, it's back in the default configuration.

Another way to deal with the touchpad is to use syndaemon in a command line with some parameters to disable touchpad and all (see http://www.webupd8.org/2009/11/ubuntu-automatically-disable-touchpad.html for configurations). But in my fresh install, when I launch syndameon, whatever the parameters are, it just seems to destroy the handling of the touchpad, that is, no more two fingers scrolling and no more "tap to click". I must reload the session to get it working again.

So I'm quite in a mist of conjecture for now: is it a bug specific to the Macbook Pro touchpads? Or am I not pushing the right buttons? Or what? Next to Unity, my main deskop environment, I installed Cynnamon desktop, maybe some package in it is messing up the touchpad settings?

  • I can't find gpointing-devices-settings anywhere – Michael Jul 7 '18 at 20:48
1

Well, I think I may have found a solution, with a direct edition of the paremeters for the touchpad from the g-conf-editor.

You have first to install G-conf-editor from the Ubuntu Software Center or via the terminal (sudo apt-get install gconf-editor).

Then switch to the subfolder Desktop > Gnome > Periphericals > bcm5974 where you can check or uncheck the options you need. I checked everything: disable_tapping, palm_detection, palm_detection_depth, palm_detection_width.

After one hour writing stuff with LibreOffice, seems like the touchpad is disabled at last when typping...

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.