I'd like to play with the Rust language on Ubuntu, but there don't seem to be any packages. Did I miss it or is there some problem?

4 Answers 4


On ubuntu 16.04 you can use official apt package without install any other ppa repository.

sudo apt install rustc

... and don't forget cargo

sudo apt install cargo

... but the versions are not really updated: (August 2016) rustc 1.7.0 and cargo 0.8.0. Unfortunally cargo is not compatible with IDEA rust plugin... I used the script pointed in Rust Documentation.

  • 1
    I haven't worked with Rust yet, but I've got good experiences with tools that manage multiple installations in other languages: rbenv for Ruby, nvm for Node.js and so on. rustup.rs seems to be something similar for Rust. You should be able to use the current versions of Rust and Cargo with it, independently of what is packaged for Ubuntu. Dec 8, 2016 at 2:30
  • By installing rustc, the cargo will be installed too!
    – Amir Fo
    May 4, 2020 at 16:50
  • Tried this on Ubuntu 20.04, and while it installs it, I can't seem to figure out where to find rustup
    – eri0o
    Jul 21, 2020 at 1:05

Jonathon Fernyhough has a PPA (personal package archive) where he provides unofficial nightly and versioned builds of rust, but it does require libstdc++ 6.x (Xenial uses 5.4.0). With Yakkety you can install Rust 1.10 from the universe repository, and 1.13 with Zesty.

Rust can be installed from this PPA by running the following, as well as llvm which is now needed:

sudo add-apt-repository ppa:jonathonf/rustlang (accept to add llvm)
sudo apt-get update
sudo apt-get install rustc

Alternatively different backport ppas like rustlang-1.13 or rustlang-test can be substituted instead of rustlang to get a the latest unstable code or a particular version.

  • 3
    That PPA seems to not be update at the moment (March 2016) - the current stable version should be 1.7, but the latest stable version in the PPA is 1.4.
    – Thomas W.
    Mar 3, 2016 at 22:14
  • 1
    It turns out it is still updated, though possibly lagging behind - currently (May 2016) 1.7 is provided.
    – Thomas W.
    May 7, 2016 at 11:56
  • 3
    The PPA seems to have been removed now (weblink is dead, sudo add-apt-repository ppa:hansjorg/rust does not work any more).
    – Thomas W.
    Aug 21, 2016 at 14:12
  • 1
    That PPA now states "You should probably just use rustup."
    – Daniel
    Mar 19, 2017 at 14:40

This answer is old

I see there is a Debian prospective package bug 689207 still open. There are initial packages but it's not ready to be in the distribution. There is also a Debian wiki page about the packaging effort.

It alludes to the fact that Rust's compiler is written in Rust so the bootstrapping process is strange, so perhaps that's why it's not packaged yet.

There are some issues in upstream Rust that make it hard to package. Bootstrapping is apparently not a catastrophic problem as packagers can start from a binary snapshot.

Updated May 2016: Happily, rustc is now in Debian testing, so should be in Ubuntu within a year or so.


I might be too late in commenting here but I found that using https://rustup.rs/ was easier. Here is what I ran in terminal to have rust installed on my Ubuntu subsystem for Windows 10:

curl https://sh.rustup.rs -sSf | sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.