12

How do I share folders in Xubuntu like in Ubuntu? I found no settings or options to share folders on my network, I do have Samba installed. I don't know what else to try. Is there a command that I can try in terminal for Xubuntu? I do see my Xubuntu machine from other computers on my network, but shows empty when I access it on other computers. Ubuntu is more user friendly for such purpose.

  • 2
    Try package system-config-samba. It is a simple graphical tool for most common samba options, including sharing. – Danatela Jul 18 '13 at 7:32
  • Thanks, I've tried it, but I every time I try to install via terminal or software center, I keep on getting installation errors. other solutions? – Orosjopie Jul 18 '13 at 8:16
  • I struggle a lot with xubuntu to get the folders on it shared, samba is installed but not helpful. Xubuntu is great on my old pc, with not userfriendly with sharing folders. Please help – Orosjopie Jul 18 '13 at 9:52
  • Then you have to ask another question and to describe what problems do you have during install. And if you seek for other solution, it may be not so simple. Look at /etc/samba/smb.conf and try to understand it's structure. It has shared folders' definitions. – Danatela Jul 18 '13 at 10:01
  • 1
    @Orosjopie What installation errors are you getting? Can you edit your question to include the complete and exact text of the error messages? – Eliah Kagan Aug 31 '13 at 16:43
13

Menu --> Settings --> Shared Folders

Or...

Execute:

shares-admin

Font: http://linuxuserlog.blogspot.com.br/2014/01/como-compartilhar-pastas-arquivos-no.html

  • This doesn't work for me in Xubuntu 18.04. – Shule Dec 29 '18 at 2:29
6

Install Samba (package name system-config-samba). If you are using Xubuntu 13.10 then also install gksu. Then go to Settings Manager -> Samba and add the desired shares.

Alternatively you can edit the /etc/samba/smb.conf file and add something like this

[set share name here]
    path = set path here
    comment = set description here
    writeable = no
    browseable = yes
    read only = yes
    guest ok = yes

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.