0

I've installed a card with two Intel 82576 ethernet ports into my PCIe expansion slot. I'm running Ubuntu server 13.04 amd64 with the 3.10 generic stable kernel.

When I run lspci | grep Ethernet I get the response:

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 04)
01:00.0 Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)
01:00.1 Ethernet controller: Intel Corporation 82576 Gigabit Network Connection (rev 01)

Ethernet controller: Intel Corporation Ethernet Connection I217-V is the onboard port, and its working just fine. The other two ports are the ones on the expension card.

When I run lshw -class network The response tells me that the two ethernet ports in question are DISABLED. The Configuration sub-section for the Intel 82576 ports show:

configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.0.3-k firmware=1.80, 0x61520001 latency=0 link=no multicast=yes port=twisted pair

I have a cable plugged into one of the ports on the card, and I'm able to see connectivity LEDs blinking away during BIOS post.

When I open /etc/udev/rules.d/70-persistent-net.rulesit shows only the on board ethernet interface and neither of the interfaces on the expansion card.

I was using this card in a previous machine that was also running Ubuntu Server 13.04 and I was able to light it up without and problems.

How do I enable my NIC?

  • 1
    That says it has no link, not that it is disabled. Plug it in. – psusi Jul 18 '13 at 3:30
  • What is the output of ifconfig -a | grep Link and sudo ethtool eth1 and replace eth1 with the port you are using. Also include the output of dmesg | grep e1000e. – gertvdijk Jul 19 '13 at 13:25
0

Thanks to gertvdijk

After running the command ifconfig -a | grep Link I got the response:

eth0      Link encap:Ethernet  HWaddr bc:5f:f4:b9:64:ea
          inet6 addr: fe80::be5f:f4ff:feb9:64ea/64 Scope:Link
lo        Link encap:Local Loopback
p1p1      Link encap:Ethernet  HWaddr 90:e2:ba:15:5a:34
p1p2      Link encap:Ethernet  HWaddr 90:e2:ba:15:5a:35

I then found this article after a quick Google search: Ubuntu 12.10: renaming ethernet interfaces from “p1p1″ to “eth0″

I named one of the Intel 82576 interfaces eth1, and left the on-board interface as eth0.

After a reboot I did a ifconfig eth1 up and its fully functional!

I don't know why the two Intel 82576 interfaces were set up as p1p1 and p1p2, some further research is required. For now, I'm happy to have it working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.