1

When I run VLC, an icon appears in the tray. When I click this icon, it pops a dropdown list containing shortcuts (hide vlc, play, stop, previous, next, speed, ...).
But the stop, previous and next are greyed out.

Note that I'm right in the middle of a playlist and that the other shortcuts (buttons on the VLC player) works fine.

Any idea why ?

2

You are using an app indicator for vlc provided by the sni-qt package, not a systray vlc icon. The reason that those buttons are greyed out is because they don't work.

Overall the indicator for vlc is pretty poor & has been that way ever since sni-qt came out. No one has fixed it so it remains just as you've seen for the last 2 years..

|improve this answer|||||
  • Mhmmm, ok. Weird thing is that I can't remember installing anything exotic like sni-qt; is it possible it got installed as a dependence of something else ? – Anto Jul 18 '13 at 6:26
  • sni-qt is part of ubuntu's default install – doug Jul 18 '13 at 15:01
  • It's possible to go back to using the actual systray icon for vlc which works flawlessly, how depends on which release of Ubuntu you are using (& there are other considerations – doug Jul 18 '13 at 15:09
  • Oh, ok. Sounds like it would be a sweet complement to the answer you gave, wouldn't it? :) – Anto Jul 19 '13 at 0:08
  • Basically you need to add vlc to the systray-whitelsit & remove the sni-qt package as it has no blacklist. How you add vlc to the whitelist depends on what release of Ubuntu you are on. (It's been removed in 13.04 so that is different answer than earlier releases. What are you using? – doug Jul 19 '13 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.