1

I have ubuntu 12.04.2 LTS AND i recently updated my system. There was a kernel update also. I tried several solutions on net. Like This , this and none of them worked for me.

I put that acpi_backlight= vendor and i was not able to change brightness at all. I removed that from grub file and i was able to change brightness from brightness and lock, function keys are still not working for brightness while volume function and other function keys are working properly.

  • What computer do you have? I've got an ASUS ZenBook and for me they started working in 13.04 when the linux kernel was updated to 3.8. Check your linux kernel by typing uname -a in a terminal. – Lars Nyström Oct 26 '13 at 9:08
0

Just to confirm, you tested both acpi_backlight=vendor and acpi_osi=linux (together and independently) and ran sudo update-grub after each attempt? Also, you might want to mention the kernel version (post the output of uname -a) as well as hardware information.

  • yes, i did grub update and tested together and independently, each time i saved grub file, i run sudo grub-update, but nothing worked for me. AND output of uname-a is -Lenovo-B480 3.5.0-36-generic #57~precise1-Ubuntu SMP Thu Jun 20 18:21:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux and It is a intel dual core processor B960, 64 bit, 500 GB hard disk, triple boot with WIndows 7, 8 and UBuntu, but there are many problems with ubuntu, even with LTS version. – Kanhiya Jul 17 '13 at 13:32
0

Try this app .. https://apps.ubuntu.com/cat/applications/brightness-controller/

I was also searching stuff related to driver , but at last I found this app . I am having ubuntu - 12.04 on Sony - vaio, working fine for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.