2

Error: "There was a problem updating a software component. Try again later and if the problem persists, contact VMware Support or your system administrator."

I get this error when trying to install VMware Tools. The Host is Xubuntu / Ubuntu 13.04 and the Guest is Windows 8. Both are 64bit. How can I fix this?

Edit: I fixed the issue by using sudo when starting VMplayer: sudo /usr/bin/vmplayer

  • 3
    Your "fix" isn't one. Never run VMPlayer as root! – guntbert Jul 16 '13 at 19:50
3

Open /var/log/vmware-installer to see what caused this error. Since this post is over two years old, I will show what my log file had for this same failure message:

[2016-11-15 15:16:41,995] ['/usr/lib/vmware-installer/2.1.0/vmware-installer.py', '--required', '--console', '--install-component=/root/.cache/vmware/cds/cdstmp_tools-netware_10.0.10_4638234/vmware-tools-netware-10.0.10-4301679.x86_64.component']
[2016-11-15 15:16:41,995] UI Initialization failed.
Traceback (most recent call last):
  File "/usr/lib/vmware-installer/2.1.0/vmware-installer.py", line 293, in main
    ui.Initialize(options.ui)
  File "/usr/lib/vmware-installer/2.1.0/vmis/ui/__init__.py", line 83, in Initialize
    exec 'from vmis.ui.null import *' in globals()
  File "<string>", line 1, in <module>
  File "/usr/lib/vmware-installer/2.1.0/vmis/ui/null.py", line 13, in <module>
    from vmis.ui import console
  File "/usr/lib/vmware-installer/2.1.0/vmis/ui/console.py", line 9, in <module>
    import curses
  File "/usr/lib/vmware-installer/2.1.0/python/lib/curses/__init__.py", line 15, in <module>
    from _curses import *
ImportError: libncursesw.so.5: cannot open shared object file: No such file or directory

As you can see, the installer wanted libncursesw.so.5. My /usr/lib and /usr/lib64 had libncursesw.so.6 but no libncursesw.so.5. One work-around is a symlink:

cd /usr/lib; ln -s libncursesw.so.6 libncursesw.so.5
cd /usr/lib64; ln -s libncursesw.so.6 libncursesw.so.5
  • 1
    Though you were helpful with your answer, giving the OP a place to start searching, I think that should be a comment. Then, if the log pointed to the same error as yours you could write an answer! – IanC Nov 15 '16 at 22:30
  • I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Nov 15 '16 at 22:32
  • Thanks for the suggestions. I have expanded the answer with more details. Since this question is over two years old, it is unlikely to ever have a selected answer. I found the question via a Google search for the same error message and am providing one reason that the VMWare installer fails at this point. Even if someone runs into a different issue, the log file will be a great starting point for other Googlers. – EpicVoyage Nov 16 '16 at 14:41
-3

Try using sudo : see if that works

sudo /usr/bin/vmplayer
  • 4
    Not good - virtualization products (like VMWare Player or Workstation) should never be run as root! – guntbert Jul 16 '13 at 19:50
  • 1
    Do you have another way to update VMplayer, without use sudo? – Bathynomus Dec 29 '13 at 14:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.