I'm trying to use Tor, but the problem is when I click on the tor browser it says it needs an update.

I grant permission (allowing execution of the file as a program) to start-tor-browser and I downloaded the most recent update bundle of Tor, but when I double click on start-tor-browser, a text file pops up, and I click on the Tor browser it says it needs an update. When I use the terminal's commands sudo start-tor-browser or sudo /start-tor-browser it says command not found.

I'm new to Linux and I have very little knowledge of the OS. If needed I can post screen shots.

  • No need to play around with permissions; just follow these steps. Jul 16 '13 at 7:09
  • Is this really an update problem? Have you successfully installed tor on Linux / that system before? Jul 16 '13 at 7:45

If you double-click on (allow-executing-file-as-program) start-tor-browser, you should be presented with a dialog of four options: Run, Run-in-Terminal, Display and Cancel. Do you see these options? If so, try Run.

Alternatively, you can set up a custom keyboard shortcut and use something like the following command (depending on where / into which folder you extracted tor):


to launch tor.

(Don't use sudo.)

If you wanted to launch tor via the command line, you could navigate to the folder and just type start-tor-browser. Given that it's just locally downloaded and not formally installed, you'll need to supply the path (or register start-tor-browser manually - but that's a separate question).

Update (mid-May 2015)

The previous command ceased to work for me. The following does work:

sh -c '"/home/user_name/where_i_put_tor/bundle/tor-browser_en-US/Browser/start-tor-browser" --detach || ([ !  -x "/home/user_name/where_i_put_tor/bundle/tor-browser_en-US/Browser/start-tor-browser" ] && "$(dirname "$*")"/Browser/start-tor-browser --detach)' dummy %k

... taken from the official Tor desktop configuration file ...

  • I don't see those options i clicked on (allow-executing-file-as-program) but still nothing I have the files downloaded in downloads and i exctracted the files in downloads I typed in "/downloads/myusername/my_tor/bundle/tor-browser_en-us/start-tor-browser" and it says command not found. Jul 16 '13 at 7:39
  • @Linuxnoobie /downloads/.... is not the complete path. Jul 16 '13 at 7:41
  • @Linuxnoobie and my_tor is just an example... so plz verify that it corresponds to your path, too. Jul 16 '13 at 7:43
  • this may sound like a supid question but how do i find what the path is? Im new at this whole thing and im not good at these things at all. would it be home/downloads/tor-browser_en-us/start-tor-browser? Jul 16 '13 at 7:56
  • :D i got the path thing Thank you so much for help this was driving me nuts :O Jul 16 '13 at 8:03

(I did read that you had already set the file to execute but I'm going to add that procedure for anyone else that stumbles into this thread with the same issue since no one has answered your question properly.)

To fix the problem of the TOR launcher not executing do the following:

  1. Right click on the file named 'start-tor-browser' and select PROPERTIES in the popup menu.
  2. Click on the PERMISSIONS tab.
  3. Click in the box 'Execute: Allow executing file as program' until you have a check mark then click the CLOSE button.

  4. On the left hand side of your Desktop in the Unity Menu list you'll see the picture of a filing cabinet. Click on the filing cabinet to open the file manager.

  5. The menu options in Ubuntu are hidden on screen by default. Press and hold the ALT key on your keyboard to reveal the menu items. In Ubuntu 14.04 you can also move your mouse up to the very top left corner of your desktop and the menu options for the active window will appear. Select EDIT then PREFERENCES.

  6. Click the BEHAVIOR tab then select the radio button next to the option 'Run executable text files when they are opened' then click the CLOSE button.

Problem solved. Your Tor launcher will work now.



If you wanted to run the application from a terminal you don't need to type the path.

  1. Press CTRL+ALT+T in Ubuntu and it will open a TERMINAL screen.
  2. Drag the 'start-tor-browser' short-cut and drop it in the TERMINAL screen you just opened.
  3. Click inside the terminal screen with your mouse to make it active and then press the ENTER key on your keyboard to execute the short-cut via the terminal.

Your app will launch and you can see all the computer stuff that is going on with the app inside the terminal. Cool! If you close the terminal it will close the app you launched as well.

If you want to launch an app from a terminal and have the ability to close the terminal without closing the app you just launched then here is another method:

  1. Press CTRL+ALT+T in Ubuntu and it will open a TERMINAL screen.
  2. type "nohup" without the quotes in the terminal screen followed with a single space.
  3. Drag the 'start-tor-browser' short-cut and drop it in the TERMINAL screen (the path automatically appears after 'nohup').
  4. Click in the terminal again and add the "&" symbol without the quotes to the end of the path we created in step 3 then press the ENTER key on your keyboard.

Here's what the command line looked like inside the Terminal on my machine:

nohup '/home/darocket/Documents/tor-browser_en-US/start-tor-browser' &

The app launches from the terminal and you can close the terminal without closing the app you launched.


As of Sep 2019 I tried from snap and apt Ubunutu 18.04 packages, both failed. Then I removed these installs, download the latest official release from https://www.torproject.org/download/ and then extracted the tar.xz file.

Then using terminal navigate to the newly extracted tor browser directory using cd command :

 cd tor-browser_en-US/

From here start tor browser:


Alternatively, register tor browser as a local application, thus create an icon shortcut accessible via menu launcher:

./start-tor-browser.desktop --register-app

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.