quite new to XUbuntu but here goes.. I've got HP Microserver that I am trying to install XUbuntu onto. No dual boot, will be XUbuntu only. So I downloaded the ubuntu ISO and made up a bootable USB stick using LiLi USB creator.

It booted up with the USB stick, and I selected to Install XUbuntu. The install seemed to go well, I selected the hard drive that I wanted to install it to, ex4 partition and a swap partition and selected this same drive as the boot drive.

Install finished and all seemed to be working well, was in the GUI etc. So I powered down and removed the USB stick.

Booted up again and got to a black screen with a flashing cursor up in the top left corner and it didn't go past this point.

Didn't see any grub menu either prior to this point - not sure if I should as it's not dual boot?

So turned off again, put USB stick back in. It booted off the USB stick and asked if I wanted to install or try ubuntu. I canceled this window (didn't select either option) and then it actually continued on and booted up I assume using the install on the hard drive.

So it seems it can't boot up without the USB stick.. Like it hasn't created the bootloader or grub or something properly?

Any ideas? Thanks

Update posted as answer

So I tried boot repair.. Didn't help. Here is the log. I am trying to run ubuntu off SDC.


I tried reinstalling again being really careful with partitions to ensure I selected SDC. But same problem just flashing cursor after reboot.

Pressing shift does nothing when trying to boot from hard drive only if USB stick is in does it take me to grub menu.

  • 3
    Seems like GRUB was installed on the USB stick by mistake. Search for boot-repair in this forum for how to fix it. Also see Accidentally installed GRUB to-USB – user68186 Jul 15 '13 at 21:50
  • 1
    When you plugged in the stick, it certainly did not boot the hard drive. The window that asks for "Install/Try Xubuntu" is the USB stick's live iso. Closing the window is equivalent to "Try Xubuntu". So you were running the USB stick. – ignis Jul 16 '13 at 9:40
  • When you boot with the USB stick plugged in, does it show you a log-in screen with your userID and ask for your password? If not, can you open a terminal and type sudo who and see if you get your userID as the user logged in. If not, you are still using the live USB stick. – user68186 Jul 16 '13 at 13:59
  • 1
    Run Ubuntu live from RAM using toram option. Then, after the data is loaded to ram, remove the pen from the USB port. That way you'll guarantee that he won't install grub on the pen. – David M. Sousa Jul 16 '13 at 14:05
  • 1
    Probably a stupid comment, but sometimes it's the most simple solution: Did you select the HDD that Ubuntu detects as sdc as boot device in BIOS? – soulsource Jul 16 '13 at 14:17

When I analized your disks state, I saw you have:

sda---------2000 GB (None OS)
sdb---------2000 GB (None OS)
sdc2--------ext Ubuntu İnstalled
sdd---------4 GB You Live USB
  1. You installed grub to sdc2.
  2. No other OS boot manager at sda.

Why not:

sdc1--------ext Ubuntu

I think I agree with soulsource. Can you check boot order in BIOS settings. Primary Boot Device should be ATA ST380811AS, not ATA ST2000DM001.

| improve this answer | |

If the bios is trying to use UEFI booting you may have success (I did) by disabling that in favor of "legacy" settings and disabling UEFI boot altogether in the boot order screen. Then cold boot (cut the power to the machine for a minute or so by pulling the plug) to the USB key and install. You'll know you are on the right track if the installation screens look different.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.