I recently received a Logitech Rumblepad 2 (a joystick, like a PS2 controller) from a friend.

How would I configure this in Ubuntu? If possible, I would prefer to use a GUI utility.

I tried jstest-gui, but it shows my accelerometer!

  • 1
    Do you mind to say what brand name and model your joystick is? – Geppettvs D'Constanzo Mar 25 '11 at 22:16
  • @GeppettvsD'Constanzo: never!!!! :D (joking) updating the question – RolandiXor Mar 25 '11 at 23:03
  • 3
    jscalibrator: - no longer available, - bugged - won't be fixed Ref: bugs.launchpad.net/ubuntu/+s...sw/+bug/416628 Looking for an alternative – user42794 Jan 20 '12 at 9:42

This process will work for Ubuntu 11.04 (Natty) and older versions. For the newest versions please refer to this Answer by RolandiXor. Thank you.

Not tested by me, but found in a link provided at: http://ubuntuforums.org/showthread.php?t=393425, I hope this may help.

Install joystick and jscalbrator

sudo apt install joystick jscalibrator

then run the calibration processes

jscal -c /dev/input/js0 (this is my joystick location, check yours)

jstest /dev/input/js0 (or wherever) If I remember correctly, this should return 0 for no error.

run jscalibrator


and it should recognize the type of gamepad correctly and recognize all of your buttons, and axis

enter image description here

enter image description here

There is also an application called jstest-gtk, which seems to do something like that, I post here a screenshot and the link for you: https://github.com/Grumbel/jstest-gtk (This software may need to be compiled in order to make it work)

enter image description here

  • 5
    Time to update this answer: $ sudo apt-get install jscalibrator Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package jscalibrator – matteo May 26 '13 at 20:16
  • 2
    The answer was updated. Please refer to this answer by RolandiXor for further support on newer versions. Thank you askubuntu.com/a/270111/9598 – Geppettvs D'Constanzo May 27 '13 at 22:05
  • I assume the first screenshot shows jscalibrator? That's exactly the software I'm searching for. Since it doesn't exist in newer versions of Ubuntu anymore, is there an alternative that actually shows what any particular button press should look like? Because I don't know what buttons 0-11 are supposed to map to so I don't know how to use jstest or jscal. If there is no such software, is there some picture that shows a reference mapping? I'm guessing X=0, O=1, square=2, triangle=4 but that's about as far as I can guess. – Christian Nov 24 '13 at 17:15
  • does some of theese tools give me the ability to choose what input driver the controller should use? like udev for example? – philx_x Apr 23 '16 at 18:44

It is possible to calibrate Joysticks in Kubuntu using KDE's system settings. This is a bit of an "overkill" solution, as of course it requires KDE (and most Ubuntu users will not want this).

enter image description here

I did not have my joystick plugged in for the above screenshot, but I have tried it before and it works.

JStest gtk and joystick

These are two tools included in the Ubuntu repositories that I have not tested recently (I found these when looking for other options). The first of the two, jstest-gtk, is a graphical tool, and joystick is a set of commandline utilities.

You can install them using:

sudo apt-get install jstest-gtk 


sudo apt-get install joystick

Jstest-gtk is a front end to joystick's commandline tools.

  • I installed kde-system-settings but can't find these settings. Where exactly are they? Do I need to install another package? – Seth Mar 19 '13 at 23:31
  • @Seth type joystick in the search box and input devices should be highlighted. – RolandiXor Mar 19 '13 at 23:35
  • I must need another package then.. See: i.stack.imgur.com/h2437.png – Seth Mar 19 '13 at 23:36
  • @Seth I would need to track it down :( – RolandiXor Mar 19 '13 at 23:39
  • 2
    I've tried jstest-gtk but it doesn't seem to allow me to change anything.. useful for testing though. – Seth Mar 19 '13 at 23:54

I'm using Ubuntu 13.04 and have Logitech Rumblepad 2. And what I did was installing these, joystick and jstest-gtk. It's already been calibrate to default and joystick device is detected right. Just plug and play.

If you need to calibrate and save your configuration you can do this, open jtest-gtk, You will see this,

enter image description here

You can calibrate by double click on the device.

enter image description here

Hope it will help you out as it has done to me.

  • How do you save your configuration? Where is it saved? In which file? – erik Sep 20 '16 at 16:00
  • This worked on 16.04 too, thanks Shaharil. – TenLeftFingers Oct 26 '17 at 11:04

The answers here are getting a bit old now, and users seem to be having issues again, so this is a current 2016 solution to configuring your joystick or gamepad on Ubuntu.

You can use antimicro, it is a fork of joy2key and has a GUI, use this PPA for 12.04 to 15.10

sudo add-apt-repository ppa:ryochan7/antimicro
sudo apt-get update
sudo apt-get install antimicro

For 16.04+ use this PPA

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install antimicro


Screnshot of AntiMicro and key mapping

  • 1
    This also worked with the droidpad application which allows android phone to be used as gamepad. – vivi Apr 16 '16 at 17:56
  • This application doesn' tedetct my USB gamepads on 15.10 - they work well on 14.04 though. Any workarounds for 15.10? – TenLeftFingers May 6 '16 at 13:30
  • I don't know a work around, it worked for me on 15.10 but here are some things to try, update your kernel and system with sudo apt-get dist-upgrade try installing the xbox driver sudo apt-get install xboxdrv reboot after each one. I also updated the answer to include a version for 16.04 if you want to upgrade. @TenLeftFingers – Mark Kirby May 6 '16 at 16:42
  • Thanks Mark Kirby. Turns out my laptop doesn't provide enough power via USB unless the power chord is connected. – TenLeftFingers May 6 '16 at 19:24
  • @TenLeftFingers (and to anyone else whose controller is not recognised when plugged in via USB cable) - something worth trying is a shorter cable. I had just grabbed the nearest one, which was pretty long. Nothing was recognised. I tried a pretty short one and both a PS2 controller and an Xbox One controller were then found using ftest /dev/input/by-id/.. – n1k31t4 Oct 25 '17 at 10:25

I am currently using qjoypad for mapping keys (even the mouse) to a Logitech Gamepad F310. It's working well for games that are designed with only keyboard and mouse controls in mind. It seems to require being run from cli as qjoypad --notray. It does use a GUI.

How to Install Qjoypad
First add the GetDeb Games ppa

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu raring-getdeb games" >> /etc/apt/sources.list.d/getdeb.list'

Then update and install package

sudo apt-get update
sudo apt-get install qjoypad

Alternatively download the package here and install with your favorite package manager.

  • qjoypad isn't in ubuntu's repository. Mind giving instructions on how to add it? – Nil May 28 '13 at 16:59
  • 1
    I seem to recall installing via the synaptic package manager. I'll check when I get home, but you can get it at qjoypad.sourceforge.net. Decompress the tar.gz and the installation should be as simple as ./config make make install – iyrin May 28 '13 at 21:51
  • 1
    doesn't look as though the package as been updated in over 3 years. Also doesn't seem like there is a ppa for it, not like it would matter given how there are no updates. It is definitely not in raring's repository. Nvm, found it ubuntuupdates.org/ppa/getdeb_games?dist=raring – Nil May 28 '13 at 22:17
  • I'm still trying to figure out how to get that notray option to run from the launcher – Nil May 29 '13 at 1:24
  • 1
    @Nil at the time of writing this, qjoypad in fact in the Ubuntu repositories. – Enkouyami May 24 '14 at 9:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.