I have a NVIDIA GeForce GTX 560 graphic card with Ubuntu 13.04 running kernel 3.8.0-19 (tried with 3.10.0-999, same issue) and whenever i tried to install NVIDIA driver, either by downloading the *.run file from http://www.nvidia.com and installing it as root (during installation it give some errors as it failed to set runlevel), or doing those following steps:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Whenever I reboot the system, all my screen is messed up (with lower resoluition that should be, and with left and top bars missing), and worked hard to uninstall this driver and get my screen resolution and bars back. Are there any secure and working way to install NVIDIA driver for that graphic card?


I had the same problem, tried every answer i could found on the net and it didn't work.

if you are in this case :

  • on startup your bios is visible only with your nvidia card
  • ubuntu is visible only with the motherboard screen outpout

the reason seems to be the bad detection of device with modern bios (new motherboard, and relative old video card).

Try doing the following : first follow the indications there : http://ubuntuguide.net/how-to-install-nvidia-graphics-driver-in-ubuntu-10-10-maverick-meerkat ie :

  • do the install of nvidia-current as suggested everywhere
  • make sure you have a xorg.conf file in /etc/X11/
  • once you are back on your problem with black screen etc, the idea is to have a terminal open from now. if you have it go to next step, otherwise try : connect your monitor to the motherboard outpout, reboot, go to the grub (double shift on startup after the bios), select the option advanced option for ubuntu, connect internet and go root console.
  • edit the xorg.conf file : sudo nano /etc/X11/xorg.conf
  • and once there : what did change everything is to add the line

    BusID "PCI:01:00:0"

in the section "Device", in my case that give this code :

Section "Device"
  Identifier     "Device0"
  Driver         "nvidia"
  VendorName     "NVIDIA Corporation"
  BusID          "PCI:01:00:0"

save (ctrl+x), connect your monitor to the nvidia card and reboot, in my case, this solved the problem.

  • Thank you, I had the exact same problem of what you describe above. Just adding "BusID" line as you suggested did the trick. – jbp Dec 17 '13 at 19:02

Try the following commands in the terminal and see if this works:

sudo apt-get install linux-source
sudo apt-get install linux
sudo apt-get autoremove nvidia-current
sudo apt-get install xserver-xorg xserver-xorg-video-all
sudo apt-add-repository ppa:noobslab/nvidia-quantal
sudo apt-get update
sudo apt-get install nvidia-current
sudo reboot

Also look at this link, it may be of use to you.


You do not have to install any PPA's at all to install nvidia drivers, simply install the nvidia-current package, though you will need to remove the PPA you added before and then do a full update.

  • Yeah, exactly. The GTX 560 is supported for any version included in Ubuntu 13.04. I don't see why this got downvoted. – gertvdijk Jul 15 '13 at 16:16

Possibly duplicate of this answer here :

How can I Install Nvidia Driver GT 520 and Cuda 5.0 in Ubuntu13.04?

It concerns CUDA-support by nvidia-driver specially written for CUDA-chipsets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.