I wanna ask about Ubuntu 12.04 LTS running on my laptop. When I run OpenOffice, the menubar is showing ___ signs, including File, View, Edit, Tools etc. then I cannot find the words on it.

enter image description here

Here's how I installed OpenOffice:

sudo add-apt-repository ppa:upubuntu-com/office
sudo apt-get update
sudo apt-get install openoffice

Please help me fix this.

I already tried to install OpenOffice just like mitch said and the package won't able to be installed. Then I tried to install LibreOffice 4 [link] (How can I install OpenOffice?) and it shows me the problems AGAIN.

  • I'm sorry, here the link i.imgbox.com/acp0Qstx.jpg – oreizakrishna Jul 15 '13 at 5:37
  • What version of OpenOffice are you running? And how did you install it exactly? Please edit your question to incorporate more information. – gertvdijk Jul 15 '13 at 5:39
  • OpenOffice 3.4 I run it on terminal via ppa – oreizakrishna Jul 15 '13 at 5:44
  • Again, please edit your question to provide all new information. And please be specific which PPA you used. (I've rolled back your earlier edit which rendered the screenshot useless - just don't touch that part - only add information.) – gertvdijk Jul 15 '13 at 5:46
  • 3
    Please note that the PPA you used hasn't been updated for a long time! launchpad.net/~upubuntu-com/+archive/office shows the last update is more than a year ago. Consider using the updated launchpad.net/~upubuntu-com/+archive/openoffice PPA (note the office changed to openoffice) Also: any reason for running OpenOffice over LibreOffice? – gertvdijk Jul 15 '13 at 5:59

First thing you need to do is to remove you current openoffice installation.

To do so, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get purge openoffice
sudo apt-get autoclean 

Also you may want to remove the PPA you added. To do that just: (Thanks to amc)

sudo apt-add-repository --remove ppa:upubuntu-com/office
sudo apt-get update

Then download openoffice 3.4.1 from their website, and choose you right architecture (Linux Intel DEB or Linux x86-64 DEB). Once downloaded, from terminal navigate to the download location (probably the Downloads folder), and run the commands below:

tar -vxzf Apache_OpenOffice_incubating_3.4.1_Linux_x86_install-deb_en-US.tar.gz
cd en-US/DEBS
sudo dpkg -i *.deb
cd desktop-integration
sudo dpkg -i *.deb

wait for the fist command to finish before running the last two commands.

On a personal note, I would go with Libreoffice as Wolter Hellmund recommended.

| improve this answer | |
  • 2
    You should also remove the ppa before installing from the downloaded deb. – amc Jul 15 '13 at 14:57
  • but LibreOffice shows me the same problem. Should I remove it too ? Thanks man – oreizakrishna Jul 15 '13 at 20:33
  • The terminal won't install the package, it shows Errors were encountered while processing:<package_name>.deb What should I do now? – oreizakrishna Jul 15 '13 at 21:46
  • You should remove Libreoffice. Which openoffice file did you download? – Mitch Jul 16 '13 at 0:48
  • I downloaded intel deb. So what now? I'm so confued – oreizakrishna Jul 16 '13 at 5:11

Here is the problem : First, I realized after all it wasn't about the broken package or configuration itself. Then I tried to run Ubuntu Tweak > Tweak > Font. I changed the default font from Ubuntu to Aurulent Sans Bold Italic this is the figure. So the LibreOffice 4 will show up like this. Thanks to all user for helping me fix the problems :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.