0

When I go to phpmyadmin it says:

The mysqli extension is missing. Please check your PHP configuration. <a href="Documentation.html#faqmysql" target="documentation"><img src="themes/dot.gif" title="Documentation" alt="Documentation" class="icon ic_b_help" /></a>

I also had wordpress installed it says:

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

So php mysql extension is not working, but it is installed.

root@john:~# sudo apt-get install  php5-mysql
Reading package lists... Done
Building dependency tree    
Reading state information... Done
php5-mysql is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I tried to remove it and re-install it but I had problems:

root@john:~# sudo apt-get purge php5-mysql
Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following packages were automatically installed and are no longer required:

  dbconfig-common libdbd-mysql-perl libmcrypt4 mysql-client mysql-client-5.5 mysql-    
client-core-5.5 php5-mcrypt
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:

  php5-mysql*

0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 245 kB disk space will be freed.
Do you want to continue [Y/n]? y

(Reading database ... 326631 files and directories currently installed.)
Removing php5-mysql ...
dpkg: error processing php5-mysql (--purge):

 subprocess installed pre-removal script returned error exit status 1

Processing triggers for libapache2-mod-php5 ...

Action 'configtest' failed.

The Apache error log may have more information.

Your apache2 configuration is broken, so we're not restarting it for you.

Errors were encountered while processing:

 php5-mysql

E: Sub-process /usr/bin/dpkg returned an error code (1)

Note: Everything was working fine till I removed some folder (maybe apache2) then when I tried to install LAMP again I have troubles.

0

mysqli is included in the php5-mysql package. Run a php script containing phpinfo() and check if MySQLi support is enabled.

If it is not, you must edit your PHP configuration. If it is not present add the following line to your php.ini file :

extension=mysqli.so

(restart Apache afterwards)

  • thanks , probleme solved by crating some files the i used to delet :) – randomuser135465 Jul 24 '13 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.