I know of the default setting in Nautilus to set the default view, but that sets it for all directories. What I'm looking for is to set the "list view" for specific folders, but Nautilus does not seem to remember my settings when I change it for a folder.

Current Behavior:

The current default view is set to Icon View. If I open Nautilus, go into a directory, say Documents, and change it to List view, it changes successfully. Subsequently, everything in this Nautilus session also changes to List view, so if I go back to my Home folder and any other folder, they're also in List view. Now, if I close and reopen Nautilus, everything is set back to Icon view, even the Documents folder.

What I've tried

  1. I've tried deleting all the files under the directory ~/.local/share/gvfs-metadata mentioned in this answer, but it didn't seem to do anything.
  2. My current setup is that /home is on a separate partition, while the subfolders (Documents, Downloads, etc...) are symlinked to an NTFS partition. I thought that might be the issue, but the same thing happens if I try what I mentioned above on a folder directly under /home/.
  3. This question is similar, but it doesn't help.
  4. I've tried installing the Thunar file manager, but it also has the same issue.
  5. I've tried installing the PCManFM file manager, but it also has the same issue.

Is this the default, normal behavior of Nautilus? Or is this a bug?

alaa@aa-lu:~$ nautilus --version
GNOME nautilus 3.6.3

alaa@aa-lu:~$ lsb_release -d
Description:    Ubuntu 13.04

3 Answers 3


Turns out that this is the actual intended behavior of Nautilus. It does not remember the view settings per folder; it's just one global setting in File > Preferences > Default View section. This change probably came starting from Nautilus 3.5.x, as pointed out in @Chriki's answer.

However, Nemo file manager does remember the view settings for each folder, so I ended up installing it.

To install the latest stable Nemo release, type the following in a terminal:

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
sudo apt-get update
sudo apt-get install nemo

Source: How to install Nemo file manager in Ubuntu


That seems to be a bug indeed, see https://bugzilla.gnome.org/show_bug.cgi?id=683802. Judging from Bugzilla comment https://bugzilla.gnome.org/show_bug.cgi?id=686499#c0 and from the fact that the required functionality is still working for me in Nautilus 3.4.2, this appears to have changed somewhere during Nautilus 3.5.x development.

BTW, just for completeness’ sake: I have also tried to change the per folder view in some symlinked NTFS folders. At least for me that worked without a problem in Nautilus 3.4.2 (Ubuntu 12.04).

  • Thanks for the bug link! However, @fossfreedom informed me (in chat) that this is the actual intended behavior of the new Nautilus. I ended up installing Nemo. I'm going to answer my question.
    – Alaa Ali
    Jul 17, 2013 at 6:36

Answer by Alaa Ali is right. However for Ubuntu 14.04 LTS, to install Nemo, use the following code

sudo add-apt-repository ppa:webupd8team/nemo 
sudo apt-get update 
sudo apt-get install nemo nemo-fileroller

Source: Intall Nemo 2.2 with Unity patches

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .