I tried to print multiple files. However not a single solution posted on the net works.

  1. either a right click using Nautilus actions as described in multiple posts
  2. Using the lpr command in the terminal and dragging files from nautilus (here printque opens but files are reld and when releasebutton is pressed the window closes without action.
  3. With a script as posted here: Printing a file from the right-click context menu in Nautilus

The only method that works is combining pdf files in pdfmod to a new large file, saving it and printing it. Not very elegant. Since no option of multiple work - could the community have a fresh look on rightclick printing from Nautilus?

  • Can you explain what it is that isn't working? I created a PDF printer just now and it works well, but I don't have a physical printer, so I can't test that. – Jo-Erlend Schinstad Jul 14 '13 at 15:39

I just added a right-click menu option that allows you to select multiple files, select Script/pdf-printer.sh and it'll create PDF files. If you choose another printer name in the script, it should use that instead, but I can't verify that. Older howtos might not work because we've moved to Gnome 3 which has a few changes. In this case, scripts have been moved from ~/.gnome2/nautilus-scripts to ~/.local/share/nautilus/scripts. Otherwise, everything should work as you would expect.

  1. Install http://apt.ubuntu.com/p/cups-pdf. This package provides a PDF printer which prints to the PDF folder in your home folder, $HOME/PDF.
  2. Open Nautilus and create a folder named PDF in your home.
  3. Press Ctrl+H in Nautilus to show hidden files.
  4. Open ~/.local/share/nautilus/scripts.
  5. Create a new file and call it "pdf-printer.sh".
  6. Paste the following:

    # pdf-printer.sh
    # Print files from the right-click context menu in Nautilus.
    # Place this script in ~/.local/share/nautilus/scripts.
    # The printer to use (as shown in the Printer Configuration
    # gui or in /etc/cups/printers.conf).
    echo "$NAUTILUS_SCRIPT_SELECTED_FILE_PATHS" | while read file
            lpr -P "$printer" "$file"
    exit 0
  7. Save the file and close it.

  8. Right-click the file and choose Properties > Permissions. Make sure the box is checked to allow executing the file.

It is possible that you have to restart nautilus for this to work. In that case, you can press Alt+F2 and enter killall nautilus. Other than that, you should now be able to select files, right click and use the script from the "script" menu.

  • 1
    To clarify what i tried to do: I wanted to printout about 10 pdf documents in oder to stick them in an envelope and snail mail them. As it was a sunny day i wanted to get done fast and not open each and every document in evince and print from there. The above solved the problem. With 3 remarks: 1. the script needs to sit here /home/[usr name]/.gnome2/nautilus-scripts im my case 2. printing i.e odt to pdf folder didnt work 3. but if you use printer=[Printername] (which you will find in the "printing" gui) then all the documents will be sent directly to the printer. Thanks! Appreciate the help. – Daniel Jul 14 '13 at 19:31
  • Tusend takk og en hilsen til Oslo! Daniel – Daniel Jul 14 '13 at 19:36
  • 1
    Glad to be of service. Please accept the answer so others can see that it was solved. – Jo-Erlend Schinstad Jul 14 '13 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.