I'm having a problem with the build in audio of my HP ProBook 4530s laptop (with Ubuntu 13.04), there is no sound at all. If I connect a USB headphone, the headphone does work correctly. So I guess the problem is related to driver for the audio chip. The audo chip detected by lspci is "Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)".

aplay -l
** List of PLAYBACK Hardware Devices **
card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.8.0-26-generic.
stephan@stephan-HP-ProBook-4530s:~$ head -n 1 /proc/asound/card*/codec#*
==> /proc/asound/card0/codec#0 <==
Codec: IDT 92HD87B1/3

==> /proc/asound/card0/codec#3 <==
Codec: Intel CougarPoint HDMI

Any ideas on how to get the audio working? The build in audio of this laptop never worked on Ubuntu, but in Windows it used to work fine.


Have you tried this instruction: HDAISHT

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.