I recently tried changing the driver for my Asus Radeon HD 7870 to the proprietary one (a friend told me it was much faster), however that seems to have killed my install of Ubuntu. Now whenever I boot up it shows me GRUB, I select Ubuntu, and then it boots up for a second or two and then blackscreens. I think the blackscreen is caused by it reaching the login screen, as it is also at that point that I can SSH into it.

So can anyone tell me how to switch back to the open source driver?

Edit: And I'll add, when I boot Ubuntu off of a USB, everything works fine.

Edit: Ok here my process is for the driver.

  1. Install Radeon HD 7870 in my system
  2. Boot up, everything is working fine automatically
  3. I go and check and it is using the open source driver (I checked by going into the Software and Updates program and going to the driver tab)
  4. A friend recommends I switch to the propietary one as it is faster (I believe it was something along the lines of flgrx-updates)
  5. I go into the Software and Updates program, and navigate to the drivers tab. From there I selected the flgrx-updates one and hit ok.
  6. I reboot my system, and then it won't work. After some basic troubleshooting, I come here.

Update: Thanks to gertvdijk I have managed to disable the propietary driver, but Ubuntu still will not beat up. I'm guessing that for whatever reason the open source driver has not been automatically enabled. Anyone have any ideas? Are there any system logs I can give you guys to help find the problem?

  • Still happening in ubuntu v14 :( – w00t Jan 7 '14 at 14:04
  • Were you able to fix this? I have tried both drivers and I think something got broken, because now, it just happens randomly... – Peter Raeves Jun 11 '14 at 10:26
  • @PeterRaeves As I said below here, I ended up just reinstalling the system partition and that did fix it. – scaru Jun 12 '14 at 0:30
  • 1
    @scaru Next time this happens to you, try purging, installing and reconfiguring the xserver-xorg. That's what just did the trick for me. – Peter Raeves Jun 12 '14 at 1:04
  • I had the same problem on ubuntu 16.04 desktop, just with nvidia drivers, but in the end story is the same: I could not login via the graphic mode, just from text console... what fixed the problem was exactly that: purging and the installing again the xserver-xorg package – Luke Nov 20 '16 at 10:44

For 14.04 and upwards, jockey-text isn't installed or available in the repository. I have just recovered from an issue where the Noveau driver caused my computer to lockup completely after logging in and I needed to go back to the nvidia driver. Here's how I did it:

At the login screen, instead of logging in I went to a terminal using CRL + ALT + F2 Type

ubuntu-drivers devices

to get a list of your devices and identify the one you want. My output looked like this:

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00000391sv00001462sd00000630bc03sc00i00
vendor : NVIDIA Corporation
model : G73 [GeForce 7600 GT]
driver : nvidia-304 - distro non-free recommended
driver : nvidia-173 - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin
driver : nvidia-304-updates - distro non-free

I wanted nvidia-304 so I typed:

apt-get install nvidia-304

Then I rebooted and confirmed using the desktop appliaction Additional Drivers that I was indeed using the driver I had chosen.

| improve this answer | |

To unistall the proprietary drivers, you should be able to simply do:

sudo apt-get remove fglrx   fglrx-amdcccle fglrx-pxpress 

if you have intalled the standard drivers, or

sudo apt-get remove fglrx-updates   fglrx-amdcccle-updates 

if you have the "updates" one.

Remember to manually delete the file /etc/X11/xorg.conf; otherwise X will still search for the proprietary drivers and will not start correctly (most of the times).

This would normally re-enable the default (open-source) drivers.

| improve this answer | |

I just wanted to chime in here because I just had the exact same problem (running Ubuntu 14.04 LTS). I selected a different video card driver in the system settings, and after rebooting, my computer prompted me to start in low-graphics mode.

What fixed the problem for me was deleting /etc/X11/xorg.conf. Now, X11 is the window manager used by Ubuntu, and it loads all files ending in .conf for its settings (at least - that's what 3 minutes of Google told me).

Since I would be hesitant to outright remove files that may in retrospect prove essential, I renamed it to something else:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo reboot

This fixed the problem for me.

Initially, my idea was to use the command line to change the video card driver back. I resorted to trying this idea because I couldn't find a way to change the video card driver. One suggested answer said to use jockey-text (How to change proprietary video driver using the command line?); however, starting with 14.04 jockey-text isn't part of Ubuntu anymore.

Some additional research: I read that X11 doesn't create an xorg.conf by default anymore. Above solution might not work for you.

| improve this answer | |
  • +1 for likely relevant answer; The content of xorg.conf file would be different, depending on which driver in use. By default, this file indeed does not exist in 14.04. Running proprietary graphic setting for the first time will likely generate xorg.conf file automatically (nvidia-settings does this, so may be similar for AMD/Radeon case). – clearkimura Jan 7 '16 at 8:47
  • Deleting xorg.conf and rebooting worked for me, Ubuntu 18.04 with an ATI GPU. – Andrew Jan 23 '19 at 15:09

After no one giving any additional answers for 2 days, I decided to try to reinstall Ubuntu. I created a Ubuntu live USB, and using that told it to reinstall Ubuntu (replaces system files, but keeps my files), and that worked perfectly.

| improve this answer | |
  • 1
    it's pretty sad that the solution is to reinstall the OS. – haventchecked Jul 5 '15 at 18:22

Run over SSH:

jockey-text --list

then identify the driver you want to disable and run

sudo jockey-text --disable driveridentification

Replace driveridentification with the ID your driver shows up with (e.g. xorg:nvidia_experimental_310 in my case). I am unable to test/verify this at the moment.

jockey-text is the command-line text-only version of the "additional drivers" application in the regular GUI. You should be able to perform the same tasks as in the regular GUI application - see the help on other tasks:

jockey-text --help

This will work in your case as you say that you can still log in using SSH. For other readers who haven't set up SSH on their machine, they'll need to boot into recovery mode or to blacklist the graphics driver kernel module on the Grub command line and then perfoming the jockey changes.

| improve this answer | |
  • I just ran that command, over SSH. It then told me I had to install jockey-commons, so I did that. Then I ran it again. This is what I got: root@david-desktop:~# jockey-text Additional Drivers Searching for available drivers... root@david-desktop:~# – scaru Jul 13 '13 at 17:43
  • @scaru Then I assume you haven't installed the Radeon driver using the "Additional drivers" application? Please include all details on how you installed the driver in the first place in your question (edit it!). If this is the case that invalidates my answer - please be more specific in your question next time! – gertvdijk Jul 13 '13 at 17:46
  • ok I just updated my original question with some more details. But yes, I did change the driver within the Additional drivers tab of the Software and Updates applciation. – scaru Jul 13 '13 at 17:52
  • @scaru Sorry about my answer being wrong - I wrongfully assumed this was an interactive application. Let me update it. – gertvdijk Jul 13 '13 at 17:53
  • ok I just tried running jockey-text --list and got this: root@david-desktop:~# jockey-text --list kmod:fglrx - Video driver for the AMD graphics accelerators (Proprietary, Disabled, Not in use) kmod:fglrx_updates - ATI Fire GL (Proprietary, Enabled, Not in use) root@david-desktop:~# So it is not listing the open source driver for whatever reason. – scaru Jul 13 '13 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.