8

Previously I advised someone on how to upgrade to Rhythmbox to version 2.99.1 here. However they couldn't upgrade due to gobject-introspection-1.0 not being installed. I couldn't help them.

Now, with a brand new computer, I am getting the same problem as they had. here is the result ov ./configure

simon@simon-TS44HR:~/Downloads/rhythmbox-2.99.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking whether make supports nested variables... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gobject-introspection... configure: error: gobject-introspection-1.0 is not installed

I tried to install gobject-introspection with the following

simon@simon-TS44HR:~/Downloads/rhythmbox-2.99.1$ sudo apt-get -f install gobject-introspection
[sudo] password for simon: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gobject-introspection is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

so I tried :

simon@simon-TS44HR:~/Downloads/rhythmbox-2.99.1$ sudo apt-get -f install gobject-introspection-1.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gobject-introspection-1.0
E: Couldn't find any package by regex 'gobject-introspection-1.0'

I have not really got to grips with installing software properly, any help would be appreciated.

  • Well, you can do sudo apt-get install libgirepository1.0-dev. But then you get an intltool error, so you do sudo apt-get install intltool. But then you get another error =D. – Alaa Ali Aug 8 '13 at 19:14
  • I had tried so many ways, but, after following your answer below, I finally got it to work. Thank you so much for your time. – SimplySimon Aug 9 '13 at 9:29
  • Man, how did you missed that the headers end in -dev? :/ – Braiam Aug 14 '13 at 5:18
14
+100

You need to install the gobject-introspection development package (library) in order for ./configure (or pkg-config) to see it. This package is libgirepository1.0-dev Install libgirepository1.0-dev. However, on my machine, ever after installing this package, I kept encountering errors on other missing dependencies for the compiling to work.

The easiest way to satisfy all the requirements for compiling Rhythmbox is to execute the command:

sudo apt-get build-dep rhythmbox

This will install a bunch of libraries and packages that are needed for compiling Rhythmbox (it will need to get around 76 MB at the time of this answer).

Once it's done, do ./configure again and it should not spit out any errors. Continue with sudo make and sudo make install.

After installing, rhythmbox might not run, and running it from the terminal will give you:

rhythmbox: error while loading shared libraries: librhythmbox-core.so.7: cannot open shared object file: No such file or directory

To fix this, do:

sudo cp /usr/local/lib/librhythmbox-core.so.7 /usr/lib

Source: [Rhythmbox-devel] Problem with 2.99.1 installation.

I just tried all of this, and it worked.

  • I started getting excited, but on sudo make I get make[2]: *** No rule to make target 'all'. Stop. in Downloads/rhythmbox-2.99.1/macros any clues what could cause this, or should I start again? – SimplySimon Aug 9 '13 at 8:57
  • I sorted it out, First I deleted the extracted files and unpacked them again, next I followed your instructions and everything ran smoothly. I am syncing my iPhone as I type :) Thank you so much. – SimplySimon Aug 9 '13 at 9:27
  • @SimplySimon I also have not been able to sync my iphone 4 (iOS 6.1.3) on Ubuntu 12.04 LTS and Rhythmbox version 2.96. If I update to the newest version of Rhythmbox following the steps above will I be able to sync my iphone with the firmware that I have? Thanks – user87317 Aug 25 '13 at 3:49
  • @user87317 I have an iPhone 5 (iOS 6.14) on Ubuntu 13.04 Desktop. Rhtythmbox version 2.99.1, and everything is working well. – SimplySimon Aug 25 '13 at 10:40
  • @SimplySimon I followed the steps above provided by Alaa but I get an error indicating that I need gtk+ >=3.6.0 but my version is 3.4.2. I did a search online but I could not find a way to update GTK without upgrading from Ubuntu 12.04. Is there a way? – user87317 Aug 25 '13 at 16:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.