Rhythmbox has been crashing a lot lately. I get three different kinds of messages before everything dies in a horrible segmentation fault.

The first, which is most common:

(rhythmbox:6475): GLib-GObject-CRITICAL **: g_value_get_uint: assertion `G_VALUE_HOLDS_UINT (value)' failed
Segmentation fault (core dumped)

The second, which is less common:

(rhythmbox:6823): GLib-CRITICAL **: g_variant_unref: assertion `value->ref_count > 0' failed

(rhythmbox:6823): GLib-GObject-CRITICAL **: g_value_get_uint: assertion `G_VALUE_HOLDS_UINT (value)' failed
Segmentation fault (core dumped)

The third, which I saw for the first time just a moment ago:

(rhythmbox:6883): GLib-GObject-CRITICAL **: g_value_get_uint: assertion `G_VALUE_HOLDS_UINT (value)' failed
Segmentation fault (core dumped)

The first message's assertion (line 6475) may or may not print several times without crashing the program.

There is no predictable pattern as to when these errors will occur. Sometimes they'll occur within 10 seconds of starting the program; other times it will run flawlessly for half an hour. Sometimes it is caused by Rhythmbox freezing.

I tried suggestions found in this post as well as this post but to no avail. I also tried reinstalling Rhythmbox after fully uninstalling and purging the packages from my system. This did not resolve the issue either.

Does anyone know how to resolve this?

  • I will note that I'm not sure if this is too close to a bug report for askubuntu. If it is, feel free to delete! Jul 12 '13 at 23:08
  • 1
    First, try to give more details about your problem: what were you doing before the errors showed? Have you tried uninstalling Rhythmbox then reinstalling it? Please give as much relevant information related to the issue as you can (at least, in your opinion). Edit your question to include any new information you can provide.
    – edwin
    Jul 12 '13 at 23:43
  • 1
    Please try the suggestions here - please edit your question with your findings. Thanks: askubuntu.com/questions/7979/…
    – fossfreedom
    Jul 13 '13 at 8:20
  • Have you installed any PPAs - if so which ones? Has any of these changed your python version? Had you tried in the past upgrading rhythmbox to another version, before later trying to downgrade it?
    – fossfreedom
    Jul 15 '13 at 15:52
  • I don't know what a PPA is; could you explain? I have not tried downgrading in the past. I've only every used Ubuntu's software updater (with the exception of 'apt-get remove --purge; apt-get install rhythmbox' in an attempt to try to remove any problematic files) to modify rhythmbox. Jul 15 '13 at 18:06

It seems the problem is caused by specific albums. I don't know why these albums are crashing Rhythmbox, but I am removing them as I find them.

Any suggestions as to how I can investigate the issue further?

  • sounds like the underlying gstreamer stuff cant cope with how the albums & tracks have been ripped. Suggest create a new question - you should explain what tools you used to rip the tracks/formats etc. It would also be worth experimenting with ripping to other formats - ogg/mp3/flac etc to see if this makes a difference.
    – fossfreedom
    Aug 12 '13 at 10:49
  • The strangest thing is that these albums have worked for years. I didn't rip them, either; I use eMusic and all other songs from there work just fine. Aug 12 '13 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.