I attempted to install openoffice with the packages that the openoffice site automatically got for me which were incorrect; RPM files insead of DEB files. The problem is after attempting to install the wrong files and the going back a trying to reinstall with the right files Ubuntu thinks there is already a working version of openoffice, which there isn't. I tried to remove it the way you would if it was the correct installation and working, that hasn't worked. So is there any way to remove every thing related to openoffice so I can try again?

  • Can you mention exactly how did you install the RPM files? What went wrong? And how did you "try to remove it the way you would if it was the correct installation"? What commands did you use for all of these, and did they give you any errors? What's the output of dpkg -l | grep openoffice? – Alaa Ali Jul 12 '13 at 18:02

You want to install aptitude first on your Ubuntu system. Run this command in Terminal to install aptitude.

    sudo apt-get install aptitude

Once that finishes, you can purge openoffice and remove it completely with this command:

    sudo aptitude purge openoffice.org

aptitude will remove all dependencies that were included with openoffice. This is why we are using this instead of apt-get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.