15

I've just bought these headphones: www.amazon.com

They have a mic button so you can talk when attached to a mobile.

If I use the headphones in a mobile (I've just tested Samsung S3 and S1) it works like a charm.

But if I use them with my Sony Laptop with Ubuntu, sound quality is really bad. If the player is flash, sound is not good. If it is not, sound is just horrible. But if I press mic button, sound is perfect!!

What can I do?

  • Try this: Insert the jack completely and then pull it out just a little bit(hardly 1mm). It might work for you. – Saty Feb 18 '18 at 17:56
  • 1
    I'm not sure this is really off-topic. The problem is caused by hardware, but some solutions are nonetheless possible in software. (The problem was also described as having been affected by what program was used...) – Eliah Kagan Aug 11 at 1:25
18

It is very simple. The headphones with mic aren't compatible with the only headphone jack.

The headphones with mic used with phone has 4 step. The standard configuration is either CTIA or OMTP. The tip is audio L, next step is audio right, 3rd step is ground (or may be mic) and 4th step is mic (or ground).

On the other hand the headphone jack only compatible with 3 pin, audio L, audio R and ground.

The reason you get horrible sound because of those last two steps. When you press the mic button, it shorts the ground with mic which intern makes your headset act like earphone without mic.

This is not related anything to ubuntu. Pure hardware issue. You need to get a 4pin to 3 pin spliter like below, or if you're having this similar problem on a mobile try the second picture

enter image description here2

  • 3
    Another simple solution which works for me is to not push the plug all the way in. Slowly push it inwards and find the place where both the left and the right channels are receiving audio. – Sicco Aug 4 '14 at 15:58
  • 2
    Or get a rubber band and put it on the remote to keep the button pressed. EDIT: Someone suggested a binder clip at the bottom of the page – Hitechcomputergeek Nov 21 '15 at 4:00
  • Does this phenomenon have a name? Do you have a link where I can read more about it? – whoKnows Mar 28 '17 at 21:11
  • @whoKnows a starting point forums.windowscentral.com/windows-phone-8-how-guides/… – Web-E Mar 29 '17 at 16:12
  • 1
    @Sicco's workaround is ideal for use with desktops, but presumably less so for laptops and mobile devices. In my case, my Xiaomi Pistons 2 (...Chi-fi IEM for the win!) behave as expected when connected directly but not when connected indirectly through a headphone extension cable. In the latter case, leaving the extension cable slightly unplugged from the input audio port of my desktop sufficed to resolve this. In short, this issue is totally absurd. (A lack of coherent standards across the hi-fi industry is why we can't have good things.) </sigh> – Cecil Curry Nov 18 '18 at 3:24
4

I would suggest going to Sound Settings and try adjusting them. The bad sound might be an issue that can be fixed through the laptops' settings... If you have tried this, please let me know for further details.

Regards, Anthie G.

enter image description here

  • I cannot resolve the issue using Sound Settings (or I don't know how to do it) – xavi Jul 12 '13 at 12:32
  • Plug your headphones in and go to sound settings. Go to the "Output" tab click on your headphones and try adjusting the settings. * See the picture above :) (I edited my answer) :) – Anthie Georgiadi Jul 12 '13 at 18:07
  • 2
    For anyone reading this: this is the answer, turn your balance all the way left or right and it will fix it – Adam May 15 '14 at 9:30
2

For the laptop, I just put a small binder clip over the microphone button, keeping it permanently pressed. Problem is most new ear bud come with the microphone, so you may have to shop around.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.