Yesterday my computer ran an update and lost flashplayer. If I try reinstalling it does the same thing which is it can't reach the source or something.

Sorry I'm not computer savvy at all, came to Ubuntu cos I had to and now don't want to leave, so I'm not so good at explaining what's wrong tecnically.

I see others have had a similar problem when updating through a proxy but I'm 99% sure my home network has no proxy's set (my flatmate assures me of this).

I'm on Ubuntu 12.04 I think and use firefox.

The install seems to run fine until it gets to:

flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.297.orig.tar.gz

it then freezes up for a bit and spits a few dummies before coming up with

Failure to download extra data files The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed. flashplugin-installer The download will be attempted again later, or you can try the download again now. Running this command requires an active Internet connection.

I then try again and it opens a new terminal where it tries to download again from the previous site. Again it just sort of freezes up and after awhile terminal closes but nothing is resolved/flash still doesn't work.

In case it's useful I'll paste my terminal script below, any help would be very appreciated as I don't really want to have to go back to using windows.

user:~$ sudo apt-get install flashplugin-installer

[sudo] password for user: 

Reading package lists... Done

Building dependency tree       

Reading state information... Done

The following packages were automatically installed and are no longer required:

  compiz-plugins compiz-plugins-main python-compizconfig python-central

Use 'apt-get autoremove' to remove them.

Suggested packages:

  x-ttcidfont-conf ttf-xfree86-nonfree xfs

The following NEW packages will be installed:


0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.

Need to get 0 B/6,932 B of archives.

After this operation, 139 kB of additional disk space will be used.

Preconfiguring packages ...

Selecting previously unselected package flashplugin-installer.

(Reading database ... 509266 files and directories currently installed.)

Unpacking flashplugin-installer (from .../flashplugin-installer_11.2.202.297ubuntu0.12.04.1_i386.deb) ...

Processing triggers for update-notifier-common ...

flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.297.orig.tar.gz

Traceback (most recent call last):

  File "/usr/lib/update-notifier/package-data-downloader", line 234, in process_download_requests
    dest_file = urllib.urlretrieve(files[i])[0]

  File "/usr/lib/python2.7/urllib.py", line 93, in urlretrieve
    return _urlopener.retrieve(url, filename, reporthook, data)

  File "/usr/lib/python2.7/urllib.py", line 239, in retrieve
    fp = self.open(url, data)

  File "/usr/lib/python2.7/urllib.py", line 207, in open
    return getattr(self, name)(url)

  File "/usr/lib/python2.7/urllib.py", line 344, in open_http

  File "/usr/lib/python2.7/httplib.py", line 954, in endheaders

  File "/usr/lib/python2.7/httplib.py", line 814, in _send_output

  File "/usr/lib/python2.7/httplib.py", line 776, in send

  File "/usr/lib/python2.7/httplib.py", line 757, in connect
    self.timeout, self.source_address)

  File "/usr/lib/python2.7/socket.py", line 571, in create_connection
    raise err

IOError: [Errno socket error] [Errno 101] Network is unreachable

Setting up flashplugin-installer ( ...

3 Answers 3


Manually download the latest adobe-flashplugin_11.2.XXX.XXX.orig.tar.gz from here, then run sudo dpkg-reconfigure flashplugin-installer. It will show this dialog:

enter image description here

Just enter the directory where you've saved the file.

  • Thanks man, worked perfectly and nice and simple, cheers :)
    – Sheed
    Jul 26, 2013 at 3:36
  • Although I now was very silly and let updates try update flash again which again ruined it. But still have all I need for this answer to work but when I type in the directory i.e. /home/user/Documents etc. it keeps saying it can't find the .tar.gz file in that directory :(
    – Sheed
    Sep 18, 2013 at 23:27
  • Not Found The requested URL /pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.297.orig.tar.gz was not found on this server. Apache/2.2.14 (Ubuntu) Server at archive.canonical.com Port 80 May 20, 2014 at 8:25
  • @therobyouknow Link updated. May 20, 2014 at 8:29
  • Thanks @EricCarvalho - before I read your update, I did this: sudo apt-get remove --purge flashplugin-installer then downloaded the .deb from link on this page: packages.ubuntu.com/lucid/amd64/flashplugin-installer/download Then ran the .deb file Just visited youtube.com on Firefox and Flash content seems to play OK May 20, 2014 at 8:33

Have you try this:

  sudo apt-get install --reinstall flashplugin-nonfree && sudo dpkg-reconfigure -a

and it might work fine this way.


Too difficult for linux illiterate people like myself. Just install google chrome (cant do this via ubuntu software centre, therefore do it via simple google internet search).

Then use google chrome-


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .