1

I have a Schiit Modi USB DAC. I cannot get it to play audio.

What should I configure to get this DAC working?

What other relevant info should I provide? The DAC is known to be working (works fine in OSX and Windows).

  • Could you clarify if the system recognises it at all? For example, does any power light or similar go on? Could you also post the output of lsusb from the terminal? – papukaija Jul 11 '13 at 23:37
  • I can confirm that I Schiit Modi Multibit (gen 2) working with Kubuntu 18.04 LTS, but so far only when using PulseAudio. – Loke Jun 13 '18 at 19:43
1

I recently got mine working but I could only do so easily using pulseaudio. Use something like pavucontrol (sudo apt-get install pavucontrol) to control which soundcard to use by default.

In pavu, under the output devices tab, click on the green checkmark button lined up with Schiit USB Audio Device Analog Stereo. Now play some music and enjoy.

0

Like the OP, I also could not get the Schiit Modi DAC working with Ubuntu (12.04). Specifically, the device was not listed in pavucontrol. Here's what worked for me:

  1. Installed the 3.11 kernel

    sudo apt-get install linux-image-3.11.0-24-generic
    
  2. After booting with the new kernel, my nvidia driver (and therefore video) was messed up. I needed to install the 331 nvidia driver for compatibility with 3.11.

    sudo apt-get install nvidia-331
    

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.