I have installed a maas server and created 3 nodes.

The MAAS web gui states 3 nodes in MAAS, 3 nodes deployed.

I created my envirment.yaml file and ran juju bootstrap, and it said it ran without issue.

When I run juju status all it does is waits for zookeeper but I always get a connection refused.

2013-07-11 15:52:03,148:2744(0x7f337d7fe700):ZOO_ERROR@handle_socket_error_msg@1579: Socket [] zk retcode=-4, errno=111(Connection refused): server refused to accept the client

I have read online that it just needs time but it has been stuck on this for over 24 hours.

I can ssh to all three hosts from maas, and zookeeper is up and running on one of the nodes with 2181 listening.

If I do juju ssh 1 then I get the same error.

Anyone have any idea ?


"3 nodes deployed"

It sounds like you're allocating the nodes in the MAAS ui before running the bootstrap. Don't do that, it means juju has no machines to allocate to itself.

Use maas-cli to release the nodes (this functionality is not in the UI yet) and I think bootstrap will then be able to allocate a node, or if not re-run bootstrap.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.