It's NTFS. It's USB2. I'm using Ubuntu 13.04. It works perfectly fine on Windows (which excludes cable and hardware problems). I have two Ubuntu computers and it's not detected on either. It's about 500 GB.

Bottomline: video explaining the solution


Following the first link, I input sudo lsusb in a terminal; before and after connecting the HDD. The difference was Bus 001 Device 012: ID 14cd:6116 Super Top M6116 SATA Bridge. There it is! ("sata bridge" used to appear in a windows notification when I plugged in the HDD in!). ...This means that Ubuntu detects it but is it not mounting it?

I tried this:

sudo mount /dev/sdb1 /mnt

But gives this:

mount: special device /dev/sdb1 does not exist

I also tried:

sudo mount /dev/sdc1 /mnt

but it stays with no output forever. I left it in background for about 30 min.s.

sudo fdisk -l gives out this:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa42d04a3
 Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63       80324       40131   de  Dell Utility
/dev/sda2   *       80325   102481919    51200797+   7  HPFS/NTFS/exFAT
/dev/sda3       263874558   312580095    24352769    5  Extended
/dev/sda4       102481920   263872511    80695296    7  HPFS/NTFS/exFAT
/dev/sda5       263874560   310505471    23315456   83  Linux
/dev/sda6       310507520   312580095     1036288   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdc: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x5822aaea

 Device Boot      Start         End      Blocks   Id  System
/dev/sdc1            2048   976769023   488383488    7  HPFS/NTFS/exFAT

The part below "Partition table entries are not in disk order" takes about 5 minutes to appear.

The outputs of ls /dev/ | grep sd before and after connecting the HDD:





The second output has the lines sdd and sdd1 different from the first one.


The command sudo mount /dev/sdd1 /mnt worked after I typed in sudo fdisk -l!!! Thanks a million!! :) :)

  • Since you are sure, then here it is: please provide extra information. – January Jul 11 '13 at 16:36
  • Can you assure that it is no hardware problem like a broken cable? Does it work on other computers? Also, please remove the device and start the program "terminal" and type "ls /dev/ | grep sd". Then do the same while the device is connected and switched on. Please copy everything from the terminal and edit it into your question. – verpfeilt Jul 11 '13 at 16:36
  • my idea was that you tell me what you need to know, sry. I will edit the title. I did forget some basic information. – Mina Michael Jul 12 '13 at 17:06
  • For future searchers: make sure you try restarting your computer (that old classic) before trying anything fancy! I had this problem and a simple restart fixed it :) – user606179 Dec 23 '16 at 12:39
  • This was some old bug and I think it got fixed coz I don't get it on newer Ubuntus. Probably you got the fix in an update :D Anyway the solution doesn't do anything permanent. It was sort of a workaround @JoeRocc – Mina Michael Dec 23 '16 at 13:45

Okay here's what worked... (Here's a video explanation)

Firstly let's check if Ubuntu detects the device:

Disconnect your device then open a terminal and input ls /dev/ | grep sd and Enter. Now connect the device and input ls /dev/ | grep sd again and Enter. Now you should have two outputs. Compare them to each other.

You should find an extra line (or two) in the second output. Keep that extra line somewhere; we'll use it later.

If you can't find a difference then I don't think my solution will work for you but you can try. Probably you have a hardware problem.

(Here's the second part of the video demonstrating what's below)

Now input sudo fdisk -l in a terminal. You should see a large output.

Wait until the "prompt" (the line that looks like user@host:~$) appears again. It might take up to 5 minutes.

When the prompt appears again now you can now "mount" the device with this command:

sudo mount /dev/sdxn /mnt

Replace sdxn by the extra line you found when we did the first step.

(example: sudo mount /dev/sdb1 /mnt)

And you're done!

Summary: To mount the hard disk again later:

  • sudo fdisk -l
  • Wait
  • sudo mount /dev/sdxn /mnt
| improve this answer | |
  • 2
    sdc and sdc1 were the new ones that appared when I typed "ls /dev/ | grep sd". I did the mount command and it said "mount: you must specify the filesystem type". – gogobebe2 May 13 '16 at 22:11
  • 2
    Same problem here, I got: mount: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error – Gabriel Ziegler Oct 24 '18 at 17:24

You can look here to learn about detecting devices. Detect and mount devices

if the device is recognized, then you can try mounting the device. #mount /dev/sdb1 /home/user/someFolder

if you get errors, post them here. if you have LVM problems, you might find this helpful: http://pissedoffadmins.com/os/mount-unknown-filesystem-type-lvm2_member.html

| improve this answer | |

It is simple. Follow these steps:

    fdisk -l

This will list out the partitions. Lets assume, your disc is "xxx"

pmount xxx /media/mydisc;

Your disk will be mounted at /media/mydisc directory.

If you want to unmount it,

umount /media/mydisc;
| improve this answer | |
  • 1
    Should be mkdir -p /media/mydisc && mount xxx /media/mydisc – Zaz Dec 21 '14 at 10:41
  • I would like to know the advantage of pmount, sounds interesting... – PJ Brunet Jun 27 at 21:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.