2

I am tring to create a new plone environment using python plone-devstart.py tool. I got a bootstrap error. So i used a command bin/python bootstrap.py -d from my project directory. It(bin/python bootstrap.py -d command) worked fine before But now i got an error like

oomsys@oomsysmob-6:~/demobrun$ bin/python bootstrap.py -d
Downloading http://pypi.python.org/packages/source/d/distribute/distribute-  
0.6.49.tar.gz
Extracting in /tmp/tmpDqVwYA
Now working in /tmp/tmpDqVwYA/distribute-0.6.49
Building a Distribute egg in /tmp/tmpv4Bzyv
/tmp/tmpv4Bzyv/distribute-0.6.49-py2.7.egg
Traceback (most recent call last):
File "bootstrap.py", line 118, in <module>
ws.require('zc.buildout' + VERSION)
File "build/bdist.linux-i686/egg/pkg_resources.py", line 698, in require
File "build/bdist.linux-i686/egg/pkg_resources.py", line 600, in resolve
pkg_resources.VersionConflict: (setuptools 0.6c11 (/home/oomsys/demobrun  
/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg),    
Requirement.parse('setuptools>=0.7'))
3

You seem to be working in a virtualenv located in /home/oomsys/demobrun. The error message is stating that setuptools is of version 0.6c11, where 0.7 or higher is required. You can use pip to upgrade the package to the current release:

pip install --upgrade setuptools
| improve this answer | |
  • What about my use case where I'm not working in a virtualenv? I'm having the same issue. the only way for me to work around this error was to force zc.buildout to use an older version. – Andre Jul 21 '13 at 21:40
  • @Andre No. Just do sudo pip install --upgrade setuptools to install the site-packages Python package (note the sudo!). The Ubuntu installed setuptools package is in dist-packages still and you can manage site-packages using pip and dist-packages using apt-get. – gertvdijk Jul 21 '13 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.